您的位置:首页 > 其它

ZOJ 1002 Fire Net(DFS啊 )

2014-11-30 19:19 387 查看
题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=2

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.
A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting
through each opening.
Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.
The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided
that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.
The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures
show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a
positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces
in the input file.
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
Sample input:
4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample output:
5
1
5
2
4


Source: Zhejiang University Local Contest 2001

题意:

在一张最大为4X4的地图中,放置碉堡,所有的碉堡不能同行和同列,除非中间有墙阻隔!

求最多能放置多少个碉堡!

'.'表示能放置碉堡的位置,‘X’表示墙!

代码如下一:

#include <cstdio>
#include <cstring>
const int maxn = 7;
char mm[maxn][maxn];
int vis[maxn][maxn];
int k, maxx;
int n;
int judge(int x, int y)
{
    for(int i = x; i >= 0; i--)
    {
        if(vis[i][y] == 1)//放了碉堡
        {
            return 0;
        }
        if(mm[i][y] == 'X')//如果是墙,这个方向就不需要再继续找了
        {
            break;
        }
    }
    for(int i = x; i < n; i++)
    {
        if(vis[i][y] == 1)//放了碉堡
        {
            return 0;
        }
        if(mm[i][y] == 'X')//如果是墙,这个方向就不需要再继续找了
        {
            break;
        }
    }
    for(int j = y; j >= 0; j--)
    {
        if(vis[x][j] == 1)
            return 0;
        if(mm[x][j] == 'X')
            break;
    }
    for(int j = y; j < n; j++)
    {
        if(vis[x][j] == 1)
            return 0;
        if(mm[x][j] == 'X')
            break;
    }
    return 1;
}
void DFS()
{
    if(k > maxx)
        maxx = k;
    for(int i = 0; i < n; i++)
    {
        for(int j = 0; j < n; j++)
        {
            if(!vis[i][j] && judge(i, j) && mm[i][j] == '.')
            {
                vis[i][j] = 1;
                k++;
                DFS();
                vis[i][j] = 0;
                k--;
            }
        }
    }
}
int main()
{
    while(scanf("%d",&n) && n)
    {
        k = maxx = 0;
        memset(vis,0,sizeof(vis));
        for(int i = 0; i < n; i++)
        {
            scanf("%s",mm[i]);
        }
        DFS();
        printf("%d\n",maxx);
    }
    return 0;
}


代码二:

#include <cstdio>
#include <cstring>
const int maxn = 7;
char mm[maxn][maxn];
int vis[maxn][maxn];
int k, maxx;
int n;
int judge(int x, int y)
{
    for(int i = x; i >= 0; i--)
    {
        if(vis[i][y] == 1)//放了碉堡
        {
            return 0;
        }
        if(mm[i][y] == 'X')//如果是墙,这个方向就不需要再继续找了
        {
            break;
        }
    }
    for(int i = x; i < n; i++)
    {
        if(vis[i][y] == 1)//放了碉堡
        {
            return 0;
        }
        if(mm[i][y] == 'X')//如果是墙,这个方向就不需要再继续找了
        {
            break;
        }
    }
    for(int j = y; j >= 0; j--)
    {
        if(vis[x][j] == 1)
            return 0;
        if(mm[x][j] == 'X')
            break;
    }
    for(int j = y; j < n; j++)
    {
        if(vis[x][j] == 1)
            return 0;
        if(mm[x][j] == 'X')
            break;
    }
    return 1;
}
void DFS(int T, int k)
{
    if(k > maxx)
        maxx = k;
    if(T == n*n)
        return;
    int x = T/n;
    int y = T%n;
    if(mm[x][y]=='.' && judge(x,y))
    {
        vis[x][y] = 1;
        DFS(T+1, k+1);
        vis[x][y] = 0;
    }
    DFS(T+1, k);
}
int main()
{
    while(scanf("%d",&n) && n)
    {
        k = maxx = 0;
        memset(vis,0,sizeof(vis));
        for(int i = 0; i < n; i++)
        {
            scanf("%s",mm[i]);
        }
        DFS(0,0);
        printf("%d\n",maxx);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: