您的位置:首页 > 其它

NYOJ-5 Binary String Matching

2014-11-30 13:17 295 查看


Binary String Matching

时间限制:3000 ms  |  内存限制:65535 KB
难度:3

描述Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is
‘11’, you should output 3, because the pattern A appeared at the posit

输入The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And
it is guaranteed that B is always longer than A.
输出For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011


样例输出
3
0
3


//虽然是英文,但从输入输出可以看出这是一道一个字符串在另一个字符串中出现的次数.


#include <stdio.h>
#include <string.h>
int main()
{
int i,j,n,al,bl,s,f;
char a[11],b[1000];
while(scanf("%d",&n)!=EOF)
{
while(n--)
{
s=0;
scanf("%s%s",a,b);
al=strlen(a);
bl=strlen(b);
for(i=0;i<bl;i++)
{
if(b[i]==a[0])
{
f=1;
for(j=1;j<al;j++)
{
if(b[i+j]!=a[j])
f=0;
}
if(f) s++;
}
}
printf("%d\n",s);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: