您的位置:首页 > 其它

sicily 1500. Prime Gap

2014-11-30 11:17 183 查看
Description

The sequence of n ? 1 consecutive composite numbers (positive integers that are not prime and not equal to 1) lying between two successive prime numbers p and p + n is called a prime gap of length n. For example, 24, 25, 26, 27, 28 between 23 and 29 is a prime gap of length 6.

Your mission is to write a program to calculate, for a given positive integer k, the length of the prime gap that contains k. For convenience, the length is considered 0 in case no prime gap contains k.

Input

The input is a sequence of lines each of which contains a single positive integer. Each positive integer is greater than 1 and less than or equal to the 100000th prime number, which is 1299709. The end of the input is indicated by a line containing a single zero.

Output

The output should be composed of lines each of which contains a single non-negative integer. It is the length of the prime gap that contains the corresponding positive integer in the input if it is a composite number, or 0 otherwise. No other characters should occur in the output.

Sample Input


Copy sample input to clipboard

10
11
27
2
492170
0


Sample Output

4
0
6
0
114


分析:首先不可能输入每个数都去找一遍其周围的素数,我比较喜欢的是直接求出所需要的最大范围的素数,然后从这里面再进行下一步的计算。这里使用的是筛选法来得到素数集。


#include <iostream>

using namespace std;

int main(int argc, char const *argv[])
{
int prime[1299710];
for (int i = 2; i != 1299710; ++i) {
prime[i] = 1;
}
for (int i = 2; i != 1299710; ++i) {
if (prime[i] == 1) {
for (int j = 2 * i; j < 1299710; j += i)
prime[j] = 0;
}
} // 筛选法找素数

int num;
while (cin >> num && num != 0) {
int length = 0;
if (prime[num] != 1) {
int upperBound = 0, lowerBound = 0;
for (lowerBound = num - 1; lowerBound >= 2; --lowerBound) {
if (prime[lowerBound] == 1)
break;
}
for (upperBound = num + 1; upperBound < 1299710; ++upperBound) {
if (prime[upperBound] == 1)
break;
}
length = upperBound - lowerBound;
}
cout << length << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: