您的位置:首页 > 运维架构

UVa 10048 - Audiophobia(floyd算法)

2014-11-29 23:21 363 查看
UVa的题目地址如下:

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=989

题目的描述为:

Consider yourself lucky! Consider yourself lucky to be still breathing and having fun participating in this contest. But we apprehend that many of your descendants may not have this luxury. For, as you know, we are the dwellers
of one of the most polluted cities on earth. Pollution is everywhere, both in the environment and in society and our lack of consciousness is simply aggravating the situation.

However, for the time being, we will consider only one type of pollution ­- the sound pollution. The loudness or intensity level of sound is usually measured in decibels and sound having intensity level 130 decibels or higher is considered painful. The intensity
level of normal conversation is 60­65 decibels and that of heavy traffic is 70­80 decibels.

Consider the following city map where the edges refer to streets and the nodes refer to crossings. The integer on each edge is the average intensity level of sound (in decibels) in the corresponding street.



To get from crossing A to crossing G you may follow the following path: A­C­F­G. In that case you must be capable of tolerating sound intensity as high as 140 decibels. For the paths A­B­E­G, A­B­D­G and A­C­F­D­G you must tolerate
respectively 90, 120 and 80 decibels of sound intensity. There are other paths, too. However, it is clear that A­C­F­D­G is the most comfortable path since it does not demand you to tolerate more than 80 decibels.

In this problem, given a city map you are required to determine the minimum sound intensity level you must be able to tolerate in order to get from a given crossing to another.

Input 

The input may contain multiple test cases.

The first line of each test case contains three integers  $C (\le 100)$,  $S (\le
1000)$ and  $Q (\le 10000)$ where C indicates the number of crossings (crossings are numbered using distinct integers ranging from 1 to C), S represents the number of streets and Q is the number of queries.

Each of the next S lines contains three integers: c1, c2 and d indicating that the average sound intensity level on the street connecting the crossings c1 and c2 (  $c_1 \ne c_2$) is d decibels.

Each of the next Q lines contains two integers c1 and c2 (  $c_1 \ne c_2$) asking for the minimum sound intensity level you must be able to tolerate in order to get from crossing c1 to crossing c2.

The input will terminate with three zeros form C, S and Q.

Output 

For each test case in the input first output the test case number (starting from 1) as shown in the sample output. Then for each query in the input print a line giving the minimum sound intensity level (in decibels) you must be
able to tolerate in order to get from the first to the second crossing in the query. If there exists no path between them just print the line ``no path".

Print a blank line between two consecutive test cases.

Sample Input 

7 9 3
1 2 50
1 3 60
2 4 120
2 5 90
3 6 50
4 6 80
4 7 70
5 7 40
6 7 140
1 7
2 6
6 2
7 6 3
1 2 50
1 3 60
2 4 120
3 6 50
4 6 80
5 7 40
7 5
1 7
2 4
0 0 0

Sample Output 

Case #1
80
60
60
 
Case #2
40
no path
80

题目的思路非常清晰,就是套一个简单的floyd算法,注意一个节点到自身的噪声是0,如果两个节点不可达,则可以简单地将它们之间的噪声设为INF。另外,本题的图是无向的,也就是说,从节点i到节点j的噪声与从节点j到节点i的噪声一样。最后注意一下输出格式,每两个case之间要打印一个空行,最后的case不要打印空行,就可以通过啦~题目的Accepted代码如下:

/*
* File:   main.cpp
* Author: seedeed
*
* Created on 2014年11月29日, 下午10:18
*/

#include <cstdio>
#define MAXC 120
#define INF ((1 << 31) - 1)

using namespace std;

int noise[MAXC][MAXC];

inline int max(int a, int b) {
return a > b ? a : b;
}

inline int min(int a, int b) {
return a < b ? a : b;
}

void floyd(int countOfCrossing) {
for (int k = 1; k <= countOfCrossing; k++) {
for (int i = 1; i <= countOfCrossing; i++) {
for (int j = 1; j <= countOfCrossing; j++) {
if (i != j) noise[i][j] = min(noise[i][j], max(noise[i][k], noise[k][j]));
}
}
}
}

int main() {
int countOfCrossing, countOfStreet, countOfQuery, ca, u, v, sound;
ca = 0;
//freopen("c:\\test.txt","r",stdin);
while (scanf("%d%d%d", &countOfCrossing, &countOfStreet, &countOfQuery) > 0 && countOfCrossing && countOfStreet && countOfQuery) {
if (ca++) {
puts("");
}
printf("Case #%d\n", ca);
for (int i = 1; i <= countOfCrossing; i++) {
noise[i][i] = 0;
}
for (int i = 1; i <= countOfCrossing; i++) {
for (in
a6ab
t j = i + 1; j <= countOfCrossing; j++) {
noise[i][j] = noise[j][i] = INF;
}
}
for (int i = 0; i < countOfStreet; i++) {
scanf("%d%d%d", &u, &v, &sound);
noise[u][v] = noise[v][u] = sound;
}
floyd(countOfCrossing);
for (int i = 0; i < countOfQuery; i++) {
scanf("%d%d", &u, &v);
if (noise[u][v] == INF) {
puts("no path");
} else {
printf("%d\n", noise[u][v]);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM CC++ 算法 图论 UVa