您的位置:首页 > 其它

nyoj107&&hdu A Famous ICPC Team

2014-11-29 21:07 218 查看

A Famous ICPC Team

时间限制:1000 ms | 内存限制:65535 KB
难度:2

描述
Mr. B, Mr. G, Mr. M and their coach Professor S are planning their way to Warsaw for the ACM-ICPC World Finals. Each of the four has a square-shaped suitcase with side length Ai (1<=i<=4) respectively. They want to pack their suitcases into a large square
box. The heights of the large box as well as the four suitcases are exactly the same. So they only need to consider the large box’s side length. Of course, you should write a program to output the minimum side length of the large box, so that the four suitcases
can be put into the box without overlapping.

输入Each test case contains only one line containing 4 integers Ai (1<=i<=4, 1<=Ai<=1,000,000,000) indicating the side length of each suitcase.输出For each test case, display a single line containing the case number and the minimum side length of the large box required.样例输入
2 2 2 22 2 2 1

样例输出
Case 1: 4Case 2: 4

提示For the first case, all suitcases have size 2x2. So they can perfectly be packed in

a 4x4 large box without wasting any space.

For the second case, three suitcases have size 2x2 and the last one is 1x1. No

matter how you rotate or move the suitcases, the side length of the large box must

be at least 4.来源hdu上传者李如兵
题意:

先生,先生,M先生和他们的教练教授的计划去华沙为承办世界杯决赛。每四个有一个方形的手提箱边长AI(1≤i<=4)分别。他们想收拾自己的行李放到一个大的方形盒。的大盒子的高度以及四个手提箱是完全相同的。所以他们只需要考虑的大盒子的边的长度。当然,你应该写一个程序来输出最小边长的大盒子,使四个箱子可以放进盒不重叠。

每个测试用例包含只有一行有4个整数AI(1 < =我≤4,1≤ai≤1000000000)指示每个箱子边长度。

思路 :求出最大两个箱子长度之和 不就可以全部装下了吗

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int main()
{
int len[4];
int d=1;
while(cin>>len[0]>>len[1]>>len[2]>>len[3])
{
sort(len,len+4);
printf("Case %d: %d\n",d++,len[2]+len[3]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: