您的位置:首页 > 其它

hdu 2602 Bone Collector(01背包)

2014-11-29 12:40 316 查看

Bone Collector

[b]Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 32072 Accepted Submission(s): 13209

[/b]

[align=left]Problem Description[/align]
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



[align=left]Input[/align]
The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.

[align=left]Output[/align]
One integer per line representing the maximum of the total value (this number will be less than 231).

[align=left]Sample Input[/align]

1
5 10
1 2 3 4 5
5 4 3 2 1


[align=left]Sample Output[/align]

14题目大意:给出一个背包的容量V,以及石头的价值和体积,求出背包中能装的最大价值是多少
思路:背包系列问题的基础01背包,具体请见转载大神文章背包九讲:
http://blog.csdn.net/ling_du/article/details/41594767
2014,11,29[code]#include<stdio.h>
#include<string.h>
#define Max(a,b) (a>b? a:b)
struct node{
int vl; int vo;
}x[2000];
int main(){
int t,n,v,dp[2000],i,j;
scanf("%d",&t);
while(t--){
memset(dp,0,sizeof(dp));
scanf("%d%d",&n,&v);
for(i=1;i<=n;i++)
scanf("%d",&x[i].vl);
for(i=1;i<=n;i++)
scanf("%d",&x[i].vo);
for(i=1;i<=n;i++)
for(j=v;j>=x[i].vo;j--){
dp[j]=Max(dp[j],dp[j-x[i].vo]+x[i].vl);//背包基础方程
}
printf("%d\n",dp[v]);
}
return 0;
}

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: