您的位置:首页 > 其它

zoj 1130 poj 1392 Ouroboros Snake (欧拉路径)

2014-11-28 19:01 363 查看
Ouroboros Snake

Time Limit: 10 Seconds Memory Limit: 32768 KB

Ouroboros is a mythical snake from ancient Egypt. It has its tail in its mouth and continously devours itself.

The Ouroboros numbers are binary numbers of 2^n bits that have the property of "generating" the whole set of numbers from 0 to 2^n - 1. The generation works as follows: given an Ouroboros number, we place its 2^n bits wrapped in a circle. Then, we can take
2^n groups of n bits starting each time with the next bit in the circle. Such circles are called Ouroboros circles for the number n. We will work only with the smallest

Ouroboros number for each n.

Example: for n = 2, there are only four Ouroboros numbers. These are 0011;0110;1100; and 1001. In this case, the smallest one is 0011. Here is the Ouroboros circle for 0011:



The table describes the function o(n;k) which calculates the k-th number in the Ouroboros circle of the smallest Ouroboros number of size n. This function is what your program should compute.

Input

The input consists of several test cases. For each test case, there will be a line containing two integers n and k (1<=n<=15; 0<=k<2^n). The end of the input file is indicated by a line containing two zeros. Don��t process that line.

Output

For each test case, output o(n;k) on a line by itself.

Sample Input

2 0

2 1

2 2

2 3

0 0

Sample Output

0

1

3

2

求一个环形的二进制字符串 可以组成0-2^n-1当中所有的数

欧拉路径的应用

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>

#define eps 1e-8
#define op operator
#define MOD  10009
#define MAXN  100100
#define INF 0x7fffffff
#define MEM(a,x)    memset(a,x,sizeof a)
#define ll __int64

const int M=(int)(1<<16);

using namespace std;

int list[M];
int ans[M];
int len;
int m;

void dfs(int v)
{
    int w;
//    cout<<"vvv  "<<v<<"  list "<<list[v]<<endl;
    while(list[v]<2)
    {
        w=v*2+list[v]; list[v]++;
//        cout<<"wwww  "<<w<<endl;
//        cout<<"w&m  "<<(w&m)<<endl;
        dfs(w&m);
//        cout<<"len  "<<len<<"  ww "<<w<<endl;
        ans[len++]=w;
    }
}

int main()
{
//freopen("ceshi.txt","r",stdin);
    int n,k;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        if(n==0&&k==0)  break;
        MEM(list,0);
        len=0;
        m=(1<<(n-1))-1;
        dfs(0);
        while(k--)
            len--;
        printf("%d\n",ans[--len]);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: