您的位置:首页 > 其它

hdu3339——In Action

2014-11-28 15:38 423 查看

In Action

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4256 Accepted Submission(s): 1372



Problem Description


Since 1945, when the first nuclear bomb was exploded by the Manhattan Project team in the US, the number of nuclear weapons have soared across the globe.

Nowadays,the crazy boy in FZU named AekdyCoin possesses some nuclear weapons and wanna destroy our world. Fortunately, our mysterious spy-net has gotten his plan. Now, we need to stop it.

But the arduous task is obviously not easy. First of all, we know that the operating system of the nuclear weapon consists of some connected electric stations, which forms a huge and complex electric network. Every electric station has its power value. To start
the nuclear weapon, it must cost half of the electric network's power. So first of all, we need to make more than half of the power diasbled. Our tanks are ready for our action in the base(ID is 0), and we must drive them on the road. As for a electric station,
we control them if and only if our tanks stop there. 1 unit distance costs 1 unit oil. And we have enough tanks to use.

Now our commander wants to know the minimal oil cost in this action.


Input
The first line of the input contains a single integer T, specifying the number of testcase in the file.

For each case, first line is the integer n(1<= n<= 100), m(1<= m<= 10000), specifying the number of the stations(the IDs are 1,2,3...n), and the number of the roads between the station(bi-direction).

Then m lines follow, each line is interger st(0<= st<= n), ed(0<= ed<= n), dis(0<= dis<= 100), specifying the start point, end point, and the distance between.

Then n lines follow, each line is a interger pow(1<= pow<= 100), specifying the electric station's power by ID order.


Output
The minimal oil cost in this action.

If not exist print "impossible"(without quotes).


Sample Input
2
2 3
0 2 9
2 1 3
1 0 2
1
3
2 1
2 1 3
1
3




Sample Output
5
impossible




Author
Lost@HDU


Source
HDOJ Monthly Contest – 2010.03.06



Recommend

先计算出0到其他的点距离,然后01背包

#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 110;
const int M = 10010;
const int inf = 0x3f3f3f3f;

struct node
{
	int weight;
	int next;
	int to;
}edge[M << 1];

struct node2
{
	int w;
	int c;
}num
;

int tot, n, m;
int head
;
int dis
;
bool vis
;
int dp[M * 10];

void addedge(int from, int to, int weight)
{
	edge[tot].weight = weight;
	edge[tot].next = head[from];
	edge[tot].to = to;
	head[from] = tot++;
}

void spfa(int v0)
{
	dis[v0] = 0;
	queue <int> qu;
	while (!qu.empty())
	{
		qu.pop();
	}
	qu.push(v0);
	while (!qu.empty())
	{
		int u = qu.front();
		qu.pop();
		for (int i = head[u]; ~i; i = edge[i].next)
		{
			int v = edge[i].to;
			if (dis[v] > dis[u] + edge[i].weight)
			{
				dis[v] = dis[u] + edge[i].weight;
				qu.push(v);
			}
		}
	}
}

int main()
{
	int t, u, v, w, ret, Vol;
	bool flag;
	scanf("%d", &t);
	while (t--)
	{
		memset (dis, inf, sizeof(dis));
		memset (head, -1, sizeof(head));
		memset (dp, 0, sizeof(dp));
		memset (vis, 0, sizeof(vis));
		tot = 0;
		scanf("%d%d", &n, &m);
		for (int i = 0; i < m; ++i)
		{
			scanf("%d%d%d", &u, &v, &w);
			addedge(u, v, w);
			addedge(v, u, w);
		}
		spfa(0);
		ret = Vol = 0;
		flag = true;
		for (int i = 1; i <= n; ++i)
		{
			scanf("%d", &num[i].w);
			ret += num[i].w;
			if (dis[i] != inf)
			{
				num[i].c = dis[i];
				Vol += num[i].c;
				vis[i] = 1;
			}
		}
		int ans = inf;
		// printf("%d\n", ret);
		ret = ret / 2 + 1;
		for (int i = 1; i <= n; ++i)
		{
			if (!vis[i])
			{
				continue;
			}
			for (int j = Vol; j >= num[i].c; --j)
			{
				dp[j] = max(dp[j], dp[j - num[i].c] + num[i].w);
				if (dp[j] >= ret)
				{
					ans = min(ans, j);
				}
			}
		}
		if (ans == inf)
		{
			printf("impossible\n");
		}
		else
		{
			printf("%d\n", ans);
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: