您的位置:首页 > 其它

HDU 4730 We Love MOE Girls

2014-11-27 15:24 323 查看
Problem Description
Chikami Nanako is a girl living in many different parallel worlds. In this problem we talk about one of them.

In this world, Nanako has a special habit. When talking with others, she always ends each sentence with "nanodesu".

There are two situations:

If a sentence ends with "desu", she changes "desu" into "nanodesu", e.g. for "iloveyoudesu", she will say "iloveyounanodesu". Otherwise, she just add "nanodesu" to the end of the original sentence.

Given an original sentence, what will it sound like aften spoken by Nanako?


Input
The first line has a number T (T <= 1000) , indicating the number of test cases. For each test case, the only line contains a string s, which is the original sentence. The length of sentence s will not exceed 100, and the sentence
contains lowercase letters from a to z only.


Output
For every case, you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output which Nanako will say.


Sample Input
2
ohayougozaimasu
daijyoubudesu




Sample Output
Case #1: ohayougozaimasunanodesu
Case #2: daijyoubunanodesu




Source
2013 ACM/ICPC Asia Regional Chengdu Online

解题:
这尼玛水的题,我还WA了两次,一次没带case,急忙就艹上去了,第二次则更为SB,多输出了中间的某一位。

代码:

# include<cstdio>
# include<iostream>
# include<cstring>

using namespace std;

# define MAX 123

char s[100];

int main(void)
{
    int t;cin>>t;
    getchar();
    for ( int j = 1;j <= t;j++ )
        {
            int flag = 0;
            gets(s);
            int n = strlen(s);
            for ( int i = n-4;i < n;i++ )
                {
                    if ( s[i] == 'd'&&s[i+1] =='e'&&s[i+2] == 's'&&s[i+3] == 'u' )
                        {
                            flag = 1;
                            break;
                        }
                }
                if ( flag )
                    {
                        printf("Case #%d: ",j);
                        for ( int i = 0;i < n-4;i++ )
                            cout<<s[i];
                            cout<<"nanodesu"<<endl;
                    }
                    else
                        {
                            printf("Case #%d: ",j);
                            for ( int i = 0;i < n;i++ )
                                {
                                    cout<<s[i];
                                }
                                cout<<"nanodesu"<<endl;

                        }
        }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: