您的位置:首页 > 其它

poj 2184 Cow Exhibition 【另类01背包】

2014-11-25 23:58 399 查看
Cow Exhibition

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 9424Accepted: 3619
Description

"Fat and docile, big and dumb, they look so stupid, they aren't much

fun..."

- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for
each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS
and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input

* Line 1: A single integer N, the number of cows

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input
5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output
8

Hint

OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF

= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value

of TS+TF to 10, but the new value of TF would be negative, so it is not

allowed.

题意:有一些牛,每个牛有智力S和幽默感F两个属性,(TS是智力的和, TF是幽默感的和)求从中选出一些牛,使他们的TS与TF不为非负数,且TS+TF最大。

分析:我们可以将某一属性作为体积,另一个就当做价值,这样就转换成了背包问题。 又因为其中有负数,所以我们将原点移动到1000*100+5位置,这样就不会RE了。

心得:原来不懂,所以就百度了下,,然后就觉得:真的是道好题,开阔了眼界。。。没想到还可以这样,orz。

代码:

#include <stdio.h>
#include <string.h>
#define Min -0x3f3f3f3f
#define M 100005

int dp[M<<1];

int Max(int a, int b){
    return a>b?a:b;
}

int main(){
    int n, i, j;
    while(scanf("%d", &n) == 1){
        int mid, min, max;
        mid = min = max = M;
        //memset(dp, 0, sizeof(dp));
        for(i = 0; i < (M<<1); i ++) dp[i] = Min;  //注意初始化都初始化最小值,因为有负值,这样取dp[j+s] = Max(dp[j+s], dp[s]+f)就不会加上一个f而大于0,影响答案
        dp[M] = 0;
        int s, f;
        for(i = 0; i < n; i ++){
            scanf("%d%d",&s, &f);
            if(s > 0){
                for(j = max; j >= min; j --)
                    dp[j+s] = Max(dp[j+s], dp[j]+f);
                max += s;
            }
            else{
                for(j = min; j <= max; j ++){
                    dp[j+s] = Max(dp[j+s], dp[j]+f);
                }
                min += s;
            }
        }
        int flag = 0; int ans = 0;
        /*printf("%d..\n", max);
        printf("%d..\n", dp[max]);*/
        for(i = mid; i <= max; i ++){
            if(dp[i] >= 0){
                ans = Max(ans, i-mid+dp[i]);
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: