您的位置:首页 > 其它

hdu 4763 stone(巴什博弈)

2014-11-24 23:11 260 查看
F - Stone
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit Status Practice HDU 4764

Description

Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc... Moreover, assuming that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students.

Input

There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero.

Output

For each case, print the winner's name in a single line.

Sample Input

1 1 30 3 10 2 0 0

Sample Output

Jiang Tang Jiang

题意:给出n和k
t和j每次给出一个数 相差不超过k 并且递增
t先进行 并且第一次范围 在 1到k之间
先到达n的人输

思路:
简单博弈 运用逆推
要赢得胜利就必须占据 n-1 点 而且要避开 n-1-k ~n-2 之间的点
以此类推 可以推出 只要 (n-1)%(k+1) 不为0 第一个人就能胜利

以 10 2 为例
1 2 3 4 5 6 7 8 9 10
l l w l l w l l w

#include<cstdio>
int main()
{
int n,k;
while(scanf("%d%d",&n,&k)!=EOF)
{
if(n==0&&k==0) break;
int que=(n-1)%(k+1);
if(que>0&&que<=k) printf("Tang\n");
else printf("Jiang\n");
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: