您的位置:首页 > 其它

HDU 4707 Pet ( DFS 啊)

2014-11-23 19:54 537 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4707

Problem Description

One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three days. Nothing but cockroaches
was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere nearer than distance D. Your
task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is always one distance unit.



Input

The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space. N is the number of locations
in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room is always at location 0.



Output

For each test case, outputin a single line the number of possible locations in the school the hamster may be found.



Sample Input

1
10 2
0 1
0 2
0 3
1 4
1 5
2 6
3 7
4 8
6 9




Sample Output

2




Source

2013 ACM/ICPC Asia Regional Online
—— Warmup

题意:

Lin Ji 的仓鼠丢了,在校园里寻找,已知Lin Ji 在0的位置,输入N D,

N表示校园中点的个数,D表示仓鼠不可能在距离D之内,

接下来N-1行,输入x,y,表示x与y相邻,

(相邻两点之间的距离为1,不相邻为inf),不存在环结构。

求仓鼠可能在的位置的个数!
代码如下:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
const int MAXN = 100017;
vector<int>v[MAXN];
int n, d;
int dis[MAXN];
void dfs(int x)
{
for(int i = 0; i < v[x].size(); i++)
{
dis[v[x][i]] = dis[x]+1;
dfs(v[x][i]);
}
}

int main()
{
int t;
int x, y;
int i, j;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&d);
for(i = 0; i < n; i++)
{
v[i].clear();
}
memset(dis,0,sizeof(dis));
for(i = 0; i < n-1; i++)
{
scanf("%d%d", &x, &y);
v[x].push_back(y);
}
dfs(0);
int ans = 0;
for(i = 0; i < n; i++)
{
if(dis[i] > d)
ans++;
}
printf("%d\n",ans);
}
return 0;
}
/*
1 10 2 0 1 0 2 0 3 1 4 1 5 2 6 3 7 4 8 6 9
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: