您的位置:首页 > 其它

HDU1081 To The Max

2014-11-22 18:05 375 查看
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8503 Accepted Submission(s): 4127



[align=left]Problem Description[/align]
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle.
In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2

is in the lower left corner:

9 2

-4 1

-1 8

and has a sum of 15.

[align=left]Input[/align]
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace
(spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will
be in the range [-127,127].

[align=left]Output[/align]
Output the sum of the maximal sub-rectangle.

[align=left]Sample Input[/align]

4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2


[align=left]Sample Output[/align]

15


属于动态规划的题目,一个矩形区域如果是最大值,那么去掉最后一层,其余的也是上面的最大值。

Java代码:

import java.util.*;
import java.lang.Math;
class Main
{
public static final int maxn = 105;
public static  int[][] a = new int[maxn][maxn];
public static int[][][] dp = new int[maxn][maxn][maxn];
public static void init(){
for(int i=0;i<maxn;i++)
for(int j=0;j<maxn;j++)
for(int k = 0;k<maxn;k++)
dp[i][j][k] = 0;
}
public static void main(String[] args)
{
int n = 0;
Scanner cin = new Scanner(System.in);
while(cin.hasNextInt()){
int max = Integer.MIN_VALUE,i=1,j=1,k=1,x=0;
init();
n = cin.nextInt();
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
a[i][j] = cin.nextInt();
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
for(x=0,k=j;k>0;k--){
x += a[i][k];
dp[i][j][k] = Math.max(dp[i][j][k],dp[i-1][j][k])+x;
if(max < dp[i][j][k]) max = dp[i][j][k];
}
System.out.println(max);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: