您的位置:首页 > 其它

HDU1335_Basically Speaking【水题】

2014-11-21 21:21 239 查看
Basically Speaking

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2456    Accepted Submission(s): 931

Problem Description

The Really Neato Calculator Company, Inc. has recently hired your team to help design their Super Neato Model I calculator. As a computer scientist you suggested to the company that it would be neato if this new calculator could convert among number bases.
The company thought this was a stupendous idea and has asked your team to come up with the prototype program for doing base conversion. The project manager of the Super Neato Model I calculator has informed you that the calculator will have the following neato
features: 

It will have a 7-digit display.

Its buttons will include the capital letters A through F in addition to the digits 0 through 9.

It will support bases 2 through 16. 

 

Input

The input for your prototype program will consist of one base conversion per line. There will be three numbers per line. The first number will be the number in the base you are converting from. The second number is the base you are converting from. The third
number is the base you are converting to. There will be one or more blanks surrounding (on either side of) the numbers. There are several lines of input and your program should continue to read until the end of file is reached.

 

Output

The output will only be the converted number as it would appear on the display of the calculator. The number should be right justified in the 7-digit display. If the number is to large to appear on the display, then print "ERROR'' (without the quotes) right
justified in the display. 

 

Sample Input

1111000  2 10

1111000  2 16

2102101  3 10

2102101  3 15

  12312  4  2

     1A 15  2

1234567 10 16

   ABCD 16 15

 

Sample Output

    120

     78

   1765

    7CA

  ERROR

  11001

 12D687
   D071

题目大意:给你一个位数不超过7的进制为a的数,转换成进制为b的数,

如果转换之后的位数超过7位,则输出ERROR

思路:先将进制为a的数用字符串存起来,转换为整形数组存储,先将进

制a的数转换为10进制的整数NumA,再转换成b的进制的数,判断下位

数然后输出结果。

#include<stdio.h>
#include<string.h>

int main()
{
char s[100];
int num[100],a,b;
while(~scanf("%s%d%d",s,&a,&b))
{
int len = strlen(s);
memset(num,0,sizeof(num));
for(int i = 0; i < len; i++)
{
if(s[i]>='0' && s[i] <= '9')
num[i] = s[i] - '0';
else
num[i] = s[i] - 'A' + 10;
}
int A,NumA;
NumA = 0,A = 1;
for(int i = len-1; i >= 0; i--)
{
NumA += (num[i]*A);
A *= a;
}
char ans[100];
int k = 0;
memset(ans,0,sizeof(ans));
while(NumA)
{
char temp = NumA % b + '0';
if(temp >='0' && temp<='9')
ans[k++] = temp;
else
ans[k++] = NumA%b+'A'-10;
NumA /= b;
}
ans[k] = '\0';
if(k > 7)
printf(" ERROR\n");
else
{
for(int i = 0;i < 7-k;i++)
printf(" ");
for(int i = k-1; i >= 0; i--)
printf("%c",ans[i]);
printf("\n");
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: