您的位置:首页 > 其它

杭电1598 find the most comfortable road(并查集暴力求解)

2014-11-21 20:25 429 查看

find the most comfortable road

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4027 Accepted Submission(s): 1735



Problem Description
XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure---超级空中漫游结构)进行交流,每条SARS都对行驶在上面的Flycar限制了固定的Speed,同时XX星人对 Flycar的“舒适度”有特殊要求,即乘坐过程中最高速度与最低速度的差越小乘坐越舒服 ,(理解为SARS的限速要求,flycar必须瞬间提速/降速,痛苦呀 ),

但XX星人对时间却没那么多要求。要你找出一条城市间的最舒适的路径。(SARS是双向的)。



Input
输入包括多个测试实例,每个实例包括:

第一行有2个正整数n (1<n<=200)和m (m<=1000),表示有N个城市和M条SARS。

接下来的行是三个正整数StartCity,EndCity,speed,表示从表面上看StartCity到EndCity,限速为speedSARS。speed<=1000000

然后是一个正整数Q(Q<11),表示寻路的个数。

接下来Q行每行有2个正整数Start,End, 表示寻路的起终点。


Output
每个寻路要求打印一行,仅输出一个非负整数表示最佳路线的舒适度最高速与最低速的差。如果起点和终点不能到达,那么输出-1。


Sample Input
4 4
1 2 2
2 3 4
1 4 1
3 4 2
2
1 3
1 2




Sample Output
1
0




Author
ailyanlu
/*
呵呵,father数组把200记成了100,不知道哪儿错了。。。。嘿嘿
加油!!!
Time:2014-11-21 20:24
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int INF=1<<27;
const int MAX=2002;
int father[205];
struct Edge{
	int u,v,w;
}edge[MAX];
int find(int x){
	return father[x]==x?x:father[x]=find(father[x]);
}
bool cmp(Edge a,Edge b){
	return a.w>b.w;
}
int main(){
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF){
		for(int i=0;i<m;i++)
			scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
		sort(edge,edge+m,cmp);
		int q;	int start,end;
		int a,b;
		scanf("%d",&q);
		while(q--){
			scanf("%d%d",&start,&end);
			int minV=INF;
			for(int i=0;i<m;i++){
				
				for(int j=0;j<=n;j++) father[j]=j;
				
				for(int j=i;j<m;j++){
					a=find(edge[j].u);
					b=find(edge[j].v);
					if(a!=b) father[a]=b;
					if(find(start)==find(end)){
						minV=min(edge[i].w-edge[j].w,minV);
						break;
					}
				}
			}
			printf(minV==INF?"-1\n":"%d\n",minV);
		}
	}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: