您的位置:首页 > 产品设计 > UI/UE

HDOJ 题目1503 Advanced Fruits(LCS 递归,模板)

2014-11-21 14:03 381 查看


Advanced Fruits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1624    Accepted Submission(s): 840
Special Judge


Problem Description

The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like
a mixture between both of them. 

A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string
that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property. 

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 

 

Input

Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file. 

 

Output

For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.

 

Sample Input

apple peach
ananas banana
pear peach

 

Sample Output

appleach
bananas
pearch

 

Source

University of Ulm Local Contest 1999

 

Recommend

linle   |   We have carefully selected several similar problems for you:  1502 1501 1227 1080 1158 

 最后一个输出的实际上是pearchr
ac代码
#include<stdio.h>
#include<string.h>
int map[1010][1010],dp[1010][1010];
char s1[1010],s2[1010];
void Lcs(int len1,int len2)
{
int i,j;
for(i=0;i<=len1;i++)
{
map[i][0]=0;
}
for(j=0;j<=len2;j++)
map[0][j]=-1;
for(i=1;i<=len1;i++)
{
for(j=1;j<=len2;j++)
{
if(s1[i-1]==s2[j-1])
{
map[i][j]=1;
dp[i][j]=dp[i-1][j-1]+1;
}
else
{
if(dp[i-1][j]>=dp[i][j-1])
{
dp[i][j]=dp[i-1][j];
map[i][j]=0;
}
else
{
dp[i][j]=dp[i][j-1];
map[i][j]=-1;
}
}
}
}
}
void printfl(int i,int j)
{
if(i==0&&j==0)
return;
if(map[i][j]==1)
{
printfl(i-1,j-1);
printf("%c",s1[i-1]);
}
else
if(map[i][j]==0)
{
printfl(i-1,j);
printf("%c",s1[i-1]);
}
else
if(map[i][j]==-1)
{
printfl(i,j-1);
printf("%c",s2[j-1]);
}

}
int main()
{
//char s1[1001],s2[1001];
int len1,len2;
while(scanf("%s%s",s1,s2)!=EOF)
{
//	memset(map,0,sizeof(map));
len1=strlen(s1);
len2=strlen(s2);
memset(dp,0,sizeof(dp));
Lcs(len1,len2);
printfl(len1,len2);
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: