您的位置:首页 > 其它

HDU 1524 A Chess Game 【SG函数】

2014-11-21 00:45 295 查看

A Chess Game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1468 Accepted Submission(s): 666



Problem Description
Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting
some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot
move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again.

Do you want to challenge me? Just write your program to show your qualification!



Input
Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number
of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M
integers, which are the initial positions of chesses. A line with number 0 ends the test case.



Output
There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.



Sample Input
4
2 1 2
0
1 3
0
1 0
2 0 2
0

4
1 1
1 2
0
0
2 0 1
2 1 1
3 0 1 3
0




Sample Output
WIN
WIN
WIN
LOSE
WIN


/*

题解:第一次用sg函数解博弈问题。可以看出此题是求sg的入门题

*/
#include<cstdio>
#include<cstring>
int map[1010][1010],sg[1010];
int N; 
int dfs(int n)
{ 
    if(sg
!=-1) return sg
;//结束条件 
    int flag[1010];
    memset(flag,0,sizeof(flag));
    for(int i=0; i<N; i++)
    {
        if(map
[i]!=-1)
        flag[dfs(i)]=1;
    }
    int i=0;
    while(flag[i]) i++;
    return sg
=i;
}
    
int main()
{
   int m,k,x,temp,ans=0;;
   while(scanf("%d",&N)!=EOF)
   {
        memset(map,-1,sizeof(map));
        memset(sg,-1,sizeof(sg));
        for(int i=0; i<N; i++)
        {
            scanf("%d",&k);
            if(k==0) {sg[i]=0;}
            for(int j=0; j<k; j++)
            {
                scanf("%d",&x);
                map[i][x]=1;//构造有向无环图 
            }
        }
        while(scanf("%d",&m)&&m)
        {
            ans=0;
            for(int i=0; i<m; i++)
            {
                scanf("%d",&temp);
                ans^=dfs(temp);//组合博弈求出每个结点的sg值 
            }
            if(ans==0) printf("LOSE\n");
            else printf("WIN\n");
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: