您的位置:首页 > 其它

UVALive - 3027 Corporative Network

2014-11-20 20:43 239 查看
Corporative Network

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu
Submit Status

Description





A very big corporation is developing its corporative network. In the beginning each of the N enterprises of the corporation, numerated from 1 to N, organized its own computing and telecommunication center. Soon,
for amelioration of the services, the corporation started to collect some enterprises in clusters, each of them served by a single computing and telecommunication center as follow. The corporation chose one of the existing centers I (serving the cluster A)
and one of the enterprises J in some cluster B (not necessarily the center) and link them with telecommunication line. The length of the line between the enterprises I and J is |I � J|(mod 1000). In such a way the two old clusters are joined in a new cluster,
served by the center of the old cluster B. Unfortunately after each join the sum of the lengths of the lines linking an enterprise to its serving center could be changed and the end users would like to know what is the new length. Write a program to keep trace
of the changes in the organization of the network that is able in each moment to answer the questions of the users.

Input

Your program has to be ready to solve more than one test case. The first line of the input file will contains only the number T of the test cases. Each test will start with the number N of enterprises (5≤N≤20000). Then some number of lines (no more than 200000)
will follow with one of the commands:
E I � asking the length of the path from the enterprise I to its serving center in the moment;

I I J � informing that the serving center I is linked to the enterprise J.
The test case finishes with a line containing the word O. The I commands are less than N.

Output

The output should contain as many lines as the number of E commands in all test cases with a single number each � the asked sum of length of lines connecting the corresponding enterprise with its serving center.

Sample Input

1
4
E 3
I 3 1
E 3
I 1 2
E 3
I 2 4
E 3
O


Sample Output

0
2
3
5


Source

Regionals 2004 >> Europe
- Southeastern

分析:

并查集的简单题,路径压缩,同时维护每个点到根节点的距离d[i]。

ac代码:

#include <iostream>

#include<cstdio>

#include<algorithm>

using namespace std;

const int maxn=20000+10;

int fa[maxn],d[maxn];

int findset(int x)

{

if(x!=fa[x])

{

//fa[x]=findset(fa[x]);//

int root=findset(fa[x]);

//fa[x]=root;

d[x]+=d[fa[x]];

fa[x]=root;

}

return fa[x];

}

int main()

{

int t;

scanf("%d",&t);

while(t--)

{

int n,u,v;

char cmd[9];

scanf("%d",&n);

for(int i=1;i<=n;i++)

{

fa[i]=i;

d[i]=0;

}

while(scanf("%s",cmd)!=EOF&&cmd[0]!='O')//大写的O

{

if(cmd[0]=='I')

{

scanf("%d%d",&u,&v);

fa[u]=v;

d[u]=abs(u-v)%1000;

}

if(cmd[0]=='E')

{

scanf("%d",&u);

findset(u);

printf("%d\n",d[u]);

}

}

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: