您的位置:首页 > Web前端

HDU1323_Perfection【水题】

2014-11-20 07:35 190 查看
Perfection

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1748    Accepted Submission(s): 1051

Problem Description

From the article Number Theory in the 1994 Microsoft Encarta: "If a, b, c are integers such that a = bc, a is called a multiple of b or of c, and b or c is called a divisor or factor of a. If c is not 1/-1, b is called a proper divisor of a. Even integers,
which include 0, are multiples of 2, for example, -4, 0, 2, 10; an odd integer is an integer that is not even, for example, -5, 1, 3, 9. A perfect number is a positive integer that is equal to the sum of all its positive, proper divisors; for example, 6, which
equals 1 + 2 + 3, and 28, which equals 1 + 2 + 4 + 7 + 14, are perfect numbers. A positive number that is not perfect is imperfect and is deficient or abundant according to whether the sum of its positive, proper divisors is smaller or larger than the number
itself. Thus, 9, with proper divisors 1, 3, is deficient; 12, with proper divisors 1, 2, 3, 4, 6, is abundant." 

Given a number, determine if it is perfect, abundant, or deficient. 

 

Input

A list of N positive integers (none greater than 60,000), with 1 < N < 100. A 0 will mark the end of the list.

 

Output

The first line of output should read PERFECTION OUTPUT. The next N lines of output should list for each input integer whether it is perfect, deficient, or abundant, as shown in the example below. Format counts: the echoed integers should be right justified
within the first 5 spaces of the output line, followed by two blank spaces, followed by the description of the integer. The final line of output should read END OF OUTPUT.

 

Sample Input

15 28 6 56 60000 22 496 0

 

Sample Output

PERFECTION OUTPUT

   15  DEFICIENT

   28  PERFECT

    6  PERFECT

   56  ABUNDANT

60000  ABUNDANT

   22  DEFICIENT

  496  PERFECT

END OF OUTPUT

 

Source
Mid-Atlantic USA 1996

题目大意:如果一个数的约数和大于它,就是ABUNDANT,如果等于它,就是

PERFECT,若果小于它本身,就是DEFICIENT。

思路:按题目要求和规定判断、输出。

#include<stdio.h>

int a[110],b[110];
int main()
{
int i = 0,n;
while(~scanf("%d",&n) && n)
{
a[i] = n;
int sum = 0;
for(int j = 1; j <= n/2; j++)
if(n % j == 0)
sum += j;
if(sum==n)
b[i] = 1;
else if(sum > n)
b[i] = 2;
else if(sum < n)
b[i] = 0;
i++;
}
printf("PERFECTION OUTPUT\n");
for(int j = 0; j < i; j++)
{
printf("%5d ",a[j]);
if(b[j]==2)
printf("ABUNDANT\n");
else if(b[j]==1)
printf("PERFECT\n");
else
printf("DEFICIENT\n");
}
printf("END OF OUTPUT\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: