您的位置:首页 > 其它

POJ 3077-Rounders(水题乱搞)

2014-11-18 13:48 232 查看
Rounders

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 7697Accepted: 4984
Description

For a given number, if greater than ten, round it to the nearest ten, then (if that result is greater than 100) take the result and round it to the nearest hundred, then (if that result is greater than 1000) take that number and round it to the nearest thousand,
and so on ...
Input

Input to this problem will begin with a line containing a single integer n indicating the number of integers to round. The next n lines each contain a single integer x (0 <= x <= 99999999).
Output

For each integer in the input, display the rounded integer on its own line.

Note: Round up on fives.
Sample Input
9
15
14
4
5
99
12345678
44444445
1445
446

Sample Output
20
10
4
5
100
10000000
50000000
2000
500

题意:给一个数字,然后从最后一位开始进位,满5进1,小于5变成0,比如 12345 -> 12350->12400->12000->10000;

暴力乱搞就行了。。

[code]
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <cctype>
#include <vector>
#include <cstdio>
#include <cmath>
#include <deque>
#include <stack>
#include <map>
#include <set>
#define ll long long
#define maxn 116
#define pp pair<int,int>
#define INF 0x3f3f3f3f
#define max(x,y) ( ((x) > (y)) ? (x) : (y) )
#define min(x,y) ( ((x) > (y)) ? (y) : (x) )
using namespace std;
int x;
char  s[15];
void solve()
{
	sprintf(s,"%d",x);
	for(int i=strlen(s)-1;i>0;i--)
	{
		if(s[i]>='5')
		{
			s[i]='0';
			s[i-1]++;
		}
		else
		s[i]='0';
	}
	if(s[0]>'9'){s[0]='0';printf("1");}
	puts(s);
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&x);
		if(x<=10){printf("%d\n",x);continue;}
		solve();
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: