您的位置:首页 > 其它

pojFind The Multiple

2014-11-17 20:36 253 查看
Find The Multiple

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 18575Accepted: 7510Special Judge
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal
digits.
Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0

Sample Output
10
100100100100100100
111111111111111111
题意:寻找一个数的倍数,这个倍数只要是由1和0组成的就行了
这个题目貌似有点坑啊,最开始根本发现不了要用广搜啊,为啥会想到用广搜呢,本来开始还想着有大数呢,没想到用Long long就可以过啊,是因为没有必要计算到大数,200以内的数就都可以找到1 0倍数么

#include <iostream>
#include <cstdio>
#include <queue>

using namespace std;

int n;
long long num;
long long bfs()
{
queue <long long> q;
q.push(1);
while(!q.empty())
{
num = q.front();
q.pop();
if(num % n == 0)
{
break ;
}
q.push(num * 10);
q.push(num * 10 + 1);
}
return num;
}
int main()
{
while(~scanf("%d", &n) && n != 0)
{
bfs();
printf("%lld\n", num);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: