您的位置:首页 > 其它

题目1070:今年的第几天?

2014-11-17 01:43 239 查看
题目1070:今年的第几天?

时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:3450

解决:1913

题目描述:

输入年、月、日,计算该天是本年的第几天。

输入:

包括三个整数年(1<=Y<=3000)、月(1<=M<=12)、日(1<=D<=31)。

输出:
输入可能有多组测试数据,对于每一组测试数据,
输出一个整数,代表Input中的年、月、日对应本年的第几天。

样例输入:
1990 9 20
2000 5 1


样例输出:
263
122


参考代码:

import java.util.*;

public class Main {

public static void main(String arg[]) {

int[] month1={31,28,31,30,31,30,31,31,30,31,30,31};
Scanner sc = new Scanner(System.in);
while(sc.hasNext()){
int totaldays=0;
int year = sc.nextInt();
//闰年判断
int flag=0;
if((year%100!=0&&year%4==0) || year%400==0) flag=1;

int month = sc.nextInt();
for(int i=0;i<month-1;i++) totaldays +=month1[i];
int day = sc.nextInt();
totaldays = totaldays+day+flag;
System.out.println(totaldays);;
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: