您的位置:首页 > 产品设计 > UI/UE

POJ 2533-Longest Ordered Subsequence(DP)

2014-11-16 18:27 316 查看
Longest Ordered Subsequence

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 34454Accepted: 15135
Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN)
be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence
(1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8

Sample Output
4

最长上升子序列。。orz 傻逼居然直接把dp
输出了 后来wa了一时还没反应过来。。

dp[i]代表以i为结尾的最长上升子序列的长度,but dp
不一定最长。。其实整个dp数组就是无序的了。。可以sort后输出

O(n*n)渣比写法

[code]
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <cctype>
#include <vector>
#include <cstdio>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <set>
#define ll long long
#define maxn 1010
#define pp pair<int,int>
#define INF 0x3f3f3f3f
#define max(x,y) ( ((x) > (y)) ? (x) : (y) )
#define min(x,y) ( ((x) > (y)) ? (y) : (x) )
using namespace std;
int n,dp[maxn],a[maxn];
void solve()
{
	for(int i=2;i<=n;i++)
		for(int j=1;j<i;j++)
			if(a[i]>a[j]&&dp[i]<=dp[j])
				dp[i]=dp[j]+1;
	sort(dp+1,dp+n+1);
	printf("%d\n",dp
);
}
int main()
{
	while(~scanf("%d",&n))
	{
		for(int i=1;i<=n;i++)
		{
			dp[i]=1;
			scanf("%d",&a[i]);
		}
		solve();
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: