您的位置:首页 > 其它

Leftmost Digit(杭电1060)(求N^N的最高位)

2014-11-16 13:05 260 查看


Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13574 Accepted Submission(s): 5216



Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.



Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).



Output

For each test case, you should output the leftmost digit of N^N.



Sample Input

2
3
4




Sample Output

2
2

Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.




Author

Ignatius.L

/*本题思路: 
1,令M=N^N; 

2,分别对等式两边取对数得 log10(M)=N*log10(N),得M=10^(N*log10(N));                  

3,令N*log10(N)=a+b,a为整数,b为小数;

4,C函数:log10(),计算对数,pow(a,b)计算a^b

5,由于10的任何整数次幂首位一定为1,所以,M的首位只和N*log10(N)的小数部分有关,

   即只用求10^b救可以了;
   
6,最后对10^b取整,输出取整的这个数就行了。(因为0<=b<1,所以1<=10^b<10对

其取整,那么的到的就是一个个位,也就是所求的数)。
*/
//hdoj系统就是坑,各种CE,各种WA,多亏康晓辉指点。 
#include<stdio.h>
#include<math.h>
int main()
{
	int test;
	double n,k,a;
	scanf("%d",&test);
	while(test--)
	{
		scanf("%lf",&n);
		a=n*log10(n);
		k=a-(__int64)a; //这里强制转换需要用int64才能A,否则会w或者CE!!! 
		printf("%d\n",int(pow(10,k)));
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: