您的位置:首页 > 其它

Hdu 1004 Let the Balloon Rise

2014-11-16 10:17 323 查看

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 77211 Accepted Submission(s): 29004



[align=left]Problem Description[/align]
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color
and find the result.

This year, they decide to leave this lovely job to you.

[align=left]Input[/align]
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case
letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

[align=left]Output[/align]
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

[align=left]Sample Input[/align]

5
green
red
blue
red
red
3
pink
orange
pink
0


[align=left]Sample Output[/align]

red
pink


[align=left]map容器[/align]
[align=left] [/align]
[align=left] [/align]
#include<iostream>

#include<string>

#include<map>

using namespace std;

int main()

{

map<string,int> ball;

string s,maxs;

int n,max;

while(cin>>n&&n)

{

ball.clear();

while(n--)

{

cin>>s;

ball[s]++;

}

map<string,int>::iterator it;

max=0;

for(it=ball.begin();it!=ball.end();it++)

{

if(it->second > max)

{

max = it->second;

maxs = it->first;

}

}

cout<<maxs<<endl;

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: