您的位置:首页 > 其它

More is better(杭电1856)(并查集)

2014-11-15 23:02 323 查看


More is better

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 327680/102400 K (Java/Others)

Total Submission(s): 15434 Accepted Submission(s): 5667



Problem Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are
still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.



Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)



Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.



Sample Input

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8




Sample Output

4
2

Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), 
then A and C are also friends(indirect).

 In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
/*两个朋友合并和的时候,需要将他们每个人的朋友数也一起合并。 
*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define M 10000005
int pre[M];
int sum[M];
int k;
int find(int N)
{
	return pre
==N?N:pre
=find(pre
);
}
void join(int x,int y)
{
	int fx=find(x),fy=find(y);
	if(fx==fy)
	return;
	if(fx!=fy)
	{
		if(sum[fx]<sum[fy])
		{
			pre[fx]=fy;
			sum[fy]+=sum[fx];
			k=max(k,sum[fy]);
		}
		else
		{
			pre[fy]=fx;
			sum[fx]+=sum[fy];
			k=max(k,sum[fx]);
		}
	}
}
int main()
{
	int i,n,a,b;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=1;i<M;i++)//sum[M]初始化均为1; 
		{
			pre[i]=i;
			sum[i]=1;
		}
		if(n==0)
		printf("1\n");
		else
		{
			k=0;
		    while(n--){
			scanf("%d %d",&a,&b);
			join(a,b);}	
		    printf("%d\n",k);
	    }
	}
	return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: