您的位置:首页 > 其它

poj 2955 Brackets(区间dp)

2014-11-15 21:43 260 查看
Brackets

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 3376Accepted: 1734
Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]


while the following character sequences are not:

(, ], )(, ([)], ([(]


Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such
that for indices i1, i2, …, imwhere 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is
a regular brackets sequence.

Given the initial sequence
([([]])]
, the longest regular brackets subsequence is
[([])]
.

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters
(
,
)
,
[
, and
]
; each input test will have length between 1 and 100, inclusive.
The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input
((()))
()()()
([]])
)[)(
([][][)
end

Sample Output
6
6
4
0
6

Source

Stanford Local 2004

题意:求出最大的括号匹配数.

题解:
枚举每一段的长度,dp[i][j]保存最优解,即最大匹配数。

AC Code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<map>

#define N 100010
#define Mod 10000007
#define lson l,mid,idx<<1
#define rson mid+1,r,idx<<1|1
#define lc idx<<1
#define rc idx<<1|1
const double EPS = 1e-11;
const double PI = acos ( -1.0 );
const double E = 2.718281828;
typedef long long ll;

const int INF = 1000010;

using namespace std;

int dp[111][111];

int main()
{
    string s;
    while ( cin >> s )
    {
        if ( s == "end" )
            break;
        int lenth = s.size();
        memset ( dp, 0, sizeof dp );
        for ( int l = 1; l < lenth; l++ )///枚举长度
        {
            for ( int i = 0, j = l; j < lenth; i++, j++ )
            {
                if ( s[i] == '(' && s[j] == ')' || ( s[i] == '[' && s[j] == ']' ) )///头尾符合匹配条件
                    dp[i][j] = dp[i + 1][j - 1] + 2;
                for ( int k = i; k < j; k++ )
                    dp[i][j] = max ( dp[i][j], dp[i][k] + dp[k + 1][j] );
            }
        }
        cout << dp[0][lenth - 1] << endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: