您的位置:首页 > 其它

poj 1256 Anagram

2014-11-15 15:22 405 查看
Description

You are to write a program that has to generate all possible words from a given set of letters.

Example: Given the word "abc", your program should - by exploring all different combination of the three letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba".

In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order.

Input

The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters are to be considered
different. The length of each word is less than 13.
Output

For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order. An upper case letter goes before
the corresponding lower case letter.
Sample Input
3
aAb
abc
acba

Sample Output
Aab
Aba
aAb
abA
bAa
baA
abc
acb
bac
bca
cab
cba
aabc
aacb
abac
abca
acab
acba
baac
baca
bcaa
caab
caba
cbaa

Hint

An upper case letter goes before the corresponding lower case letter.

So the right order of letters is 'A'<'a'<'B'<'b'<...<'Z'<'z'.

题意:给出一字符串,求出所有按字母顺序排序的全排列。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
char num[15],temp[15];
int n;
bool vis[15];
bool cmp(const char &a, const char &b)
{
int x = a - 'A';
int y = b - 'A';
if (x >= 26)
{
x -= 'a' - 'A';
}
if (y >= 26)
{
y -= 'a' - 'A';
}
if (x != y)
{
return x < y;
}
return a < b;
}
void solve(int cnt)
{
bool flag[100]={0};  //用于去重,
if(cnt==n)
{
temp
='\0';
printf("%s\n",temp);
return;
}
for(int i=0;i<n;i++)
{
if(!vis[i] && flag[num[i]-'A']==0)   //flag 递归到该层中num[i]没有枚举过
{
vis[i]=true;
temp[cnt]=num[i];
flag[num[i]-'A']=1;
solve(cnt+1);
vis[i]=false;

}
}
}
int main()
{
int t;
scanf("%d",&t);
while (t--)
{
scanf("%s",num);
n=strlen(num);
sort(num,num+n, cmp);
memset(vis, false, sizeof(vis));
solve(0);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: