您的位置:首页 > 其它

[POJ 3254] Corn Fields

2014-11-15 12:00 260 查看
Corn Fields

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 8326Accepted: 4434
Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.
Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3   4

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.
Source

USACO 2006 November Gold

经典状压DP、- -

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
#define INF 0x7ffffff
#define MOD 100000000

int n,m;
int a[13];
int dp[13][5000];

bool judge(int row,int sta)            //判断第row行sta状态是否合法
{
if((a[row]&sta)!=sta) return 0;
if(sta&(sta<<1) || sta&(sta>>1)) return 0;
return 1;
}

void solve()
{
int i,j,k;
int MAX=1<<m;
dp[0][0]=1;
for(i=1;i<=n;i++)
{
for(j=0;j<MAX;j++)
{
if(!judge(i,j)) continue;
for(k=0;k<MAX;k++)
{
if(j&k) continue;
dp[i][j]=(dp[i][j]+dp[i-1][k])%MOD;
}
}
}
int res=0;
for(i=n,j=0;j<MAX;j++)
{
res=(res+dp[i][j])%MOD;
}
printf("%d\n",res);
}
int main()
{
int i,j;
while(scanf("%d%d",&n,&m)!=EOF)
{
memset(a,0,sizeof(a));
memset(dp,0,sizeof(dp));
for(i=1;i<=n;i++)
{
for(j=1;j<=m;j++)
{
int x;
scanf("%d",&x);
a[i]=(a[i]<<1)+x;       //讲每一行的状态记录下来
}
}
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: