您的位置:首页 > 其它

1005. Spell It Right (20)

2014-11-15 10:16 302 查看

1005. Spell It Right (20)

时间限制
400 ms

内存限制
32000 kB

代码长度限制
16000 B

判题程序
Standard

作者
CHEN, Yue

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345

Sample Output:
one five


这是简单题,目的是算出整数N各个位上数字的和,再将和用英文数字表示出来,从例子中我们可以看到,15它是用one five表示,而不是用fifteen表示,这其实是降低了我们的难度,我们就很自然地想到用一个String[10]数组表示0~9;题目中的N<=10^1000,实际上求出的和已经预示着不会大于1000,最多用三个字母就可以表示,但是用vector对象保存N,用一个Stack对象保存sum结果的话,实际上N可以任意大,sum也可以不止三个字母。最后是要注意输入为0的时候的处理,以及输出sum最低位时后面不要加空格。

#include<string>
#include<stack>
#include<iostream>

using namespace std;

int main(){
string input,output[10];
int i,sum = 0;
stack<int> num;

cin>>input;
for ( i = 0; i < input.size() ; i++ ){
sum += (int)(input[i]-48);
}

output[0]="zero";
output[1]="one";
output[2]="two";
output[3]="three";
output[4]="four";
output[5]="five";
output[6]="six";
output[7]="seven";
output[8]="eight";
output[9]="nine";

if ( sum == 0 )
num.push( sum );

while( sum != 0 ){
num.push(sum%10);
sum /= 10;
}

while ( !num.empty() ){
if ( 1 == num.size() )
cout<<output[num.top()];
else
cout<<output[num.top()]<<" ";
num.pop();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: