您的位置:首页 > 其它

poj 2418 Hardwood Species

2014-11-15 08:49 351 查看
Hardwood Species

Time Limit: 10000MSMemory Limit: 65536K
Total Submissions: 19313Accepted: 7609
Description

Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter.

America's temperate climates produce forests with hundreds of hardwood species -- trees that share certain biological characteristics. Although oak, maple and cherry all are types of hardwood trees, for example, they are different species. Together, all the
hardwood species represent 40 percent of the trees in the United States.

On the other hand, softwoods, or conifers, from the Latin word meaning "cone-bearing," have needles. Widely available US softwoods include cedar, fir, hemlock, pine, redwood, spruce and cypress. In a home, the softwoods are used primarily as structural lumber
such as 2x4s and 2x6s, with some limited decorative applications.

Using satellite imaging technology, the Department of Natural Resources has compiled an inventory of every tree standing on a particular day. You are to compute the total fraction of the tree population represented by each species.
Input

Input to your program consists of a list of the species of every tree observed by the satellite; one tree per line. No species name exceeds 30 characters. There are no more than 10,000 species and no more than 1,000,000 trees.
Output

Print the name of each species represented in the population, in alphabetical order, followed by the percentage of the population it represents, to 4 decimal places.
Sample Input
Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow

Sample Output
Ash 13.7931
Aspen 3.4483
Basswood 3.4483
Beech 3.4483
Black Walnut 3.4483
Cherry 3.4483
Cottonwood 3.4483
Cypress 3.4483
Gum 3.4483
Hackberry 3.4483
Hard Maple 3.4483
Hickory 3.4483
Pecan 3.4483
Poplan 3.4483
Red Alder 3.4483
Red Elm 3.4483
Red Oak 6.8966
Sassafras 3.4483
Soft Maple 3.4483
Sycamore 3.4483
White Oak 10.3448
Willow 3.4483
Yellow Birch 3.4483

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceeded.

题意:输入单词列表,然后让你输出单词以及整个单词出现的频率,输出列表的单词按照输入中出现的字典序进行排序;

解题:

STL的map用法:

map实质是一个二叉查找数,它可以做到插入、删除和查询,平均查询时间为log2(n),n为map中元素的个数,将字符串数据插入map中后,再用迭代器去访问map中的元素时,实质是按照map中插入的字符串的字典序进行访问的。

map可以建立任意两种类型的关系,格式为map<teyp1,type2>变量1,变量2;其中type1称为键,type2称为值,键是map用来索引的,而值则是相应键下所存储的信息。

#include <iostream>
#include <stdio.h>
#include <iomanip>
#include <string>
#include <string.h>
#include <map>
using namespace std;
int main(){
char str[50];
int count=0;
map<string,int> counter;
map<string,int> ::iterator it;
while (gets(str)!=NULL){
counter[str]++;
count++;
}
for (it=counter.begin();it!=counter.end();it++){
cout<<(it->first)<<" "<<fixed<<setprecision(4)<<(it->second)*1.0/count*100<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: