您的位置:首页 > 其它

poj 2151 Check the difficulty of problems

2014-11-14 21:49 316 查看
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 5109Accepted: 2261
Description
Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:

1. All of the teams solve at least one problem.

2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you
calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input
The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range
of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.
Output
For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input
2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output
0.972

题意:    ACM比赛中,共M道题,T个队,pij表示第i队解出第j题的概率                问 每队至少解出一题且冠军队至少解出N道题的概率。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<queue>
#include<vector>
#include<cstring>
using namespace std;
typedef long long LL;
double dp[1001][31][31];
double solve[1001][31];
double s[1001][31];
/**
dp[i][j][k]表示i号队前j道题做对k题的概率, solve[i][j]表示i号队解决j题的概率,
不难得出 dp[i][j][k] = dp[i][j-1][k]*(1-solve[i][j]) + dp[i][j-1][k-1]*solve[i][j];
其中dp[i][m][k]表示i号队伍最终做对k题的概率。
令s[i][j] 表示i号队伍做对0道,1道...j道题的概率。
最终答案可以用"所有队伍至少做对1题的概率" - "所有队伍至少做对1道且最多做对n-1道"
表示,即∏(s[i][m]-s[i][0]) - ∏(s[i][n-1]-s[i][0]);
*/
int main()
{
//freopen("date.in","r",stdin);

int i,j,k,m,n,t;
while(scanf("%d %d %d",&m,&t,&n)==3, m+t+n){
for(i=1;i<=t;i++)
for(j=1;j<=m;j++)
scanf("%lf",&solve[i][j]);
for(i=1;i<=t;i++){
dp[i][0][0] = 1;
for(j=1;j<=m;j++){
dp[i][j][0] = dp[i][j-1][0]*(1-solve[i][j]);
for(k=1;k<=j;k++)
dp[i][j][k] = dp[i][j-1][k-1]*solve[i][j]+dp[i][j-1][k]*(1-solve[i][j]);
}
s[i][0] = dp[i][m][0];
for(j=1;j<=m;j++) s[i][j] = s[i][j-1]+dp[i][m][j];
}
double p1 = 1, p2 = 1;
for(i=1;i<=t;i++) p1*=s[i][m]-s[i][0], p2*=s[i][n-1]-s[i][0];
printf("%.3f\n",p1-p2);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: