您的位置:首页 > 运维架构

Poj OpenJudge 百练 1860 Currency Exchang

2014-11-14 17:25 351 查看
1.Link:

http://poj.org/problem?id=1860

http://bailian.openjudge.cn/practice/1860

2.Content:


Currency Exchange

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 20706Accepted: 7428
Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.
Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104.
Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

Source

Northeastern Europe 2001, Northern Subregion

3.Method:

此题重在知道使用Bellman-Ford算法

算法原理参考:

(1)算法艺术与信息学竞赛 307页

(2)http://baike.baidu.com/view/1481053.htm

思路参考了:
http://blog.csdn.net/lyy289065406/article/details/6645778 http://www.cppblog.com/MemoryGarden/archive/2008/09/04/60912.html (这个思路有问题,一开始我也是这种思路)

4.Code:

#include <iostream>
#include <cstring>

using namespace std;

struct Exchange
{
int a;
int b;
double r;
double c;
};

int main()
{
//freopen("D://input.txt","r",stdin);

int i,j;

int n,m,s;
double v;

cin >> n >> m >> s >> v;

Exchange *arr_ec = new Exchange[m * 2];

int a,b;
double rab,cab,rba,cba;
for(i = 0; i < m; ++i)
{
cin >> a >> b >> rab >> cab >> rba >> cba;

arr_ec[i * 2].a = a - 1;
arr_ec[i * 2].b = b - 1;
arr_ec[i * 2].r = rab;
arr_ec[i * 2].c = cab;

arr_ec[i * 2 + 1].a = b - 1;
arr_ec[i * 2 + 1].b = a - 1;
arr_ec[i * 2 + 1].r = rba;
arr_ec[i * 2 + 1].c = cba;
}

//for(i = 0; i < m * 2; ++i) cout << arr_ec[i].a << " " << arr_ec[i].b << " " << arr_ec[i].r << " " << arr_ec[i].c << endl;

double *d = new double
;
memset(d, 0, sizeof(double) * n);
d[s - 1] = v;

//for(i = 0; i < n; ++i) cout << d[i] << " ";

//Bellman-Ford
int flag;
for(i = 1; i <= n - 1; ++i)
{
flag = 0;
for(j = 0; j < 2 * m; ++j)
{
if(d[arr_ec[j].b] < (d[arr_ec[j].a] - arr_ec[j].c) * arr_ec[j].r)
{
d[arr_ec[j].b] = (d[arr_ec[j].a] - arr_ec[j].c) * arr_ec[j].r;
flag = 1;
}
}
if(!flag) break;
//for(j = 0; j < n; ++j) cout << d[j] << " ";
//cout << endl;
}

for(i = 0; i < 2 * m; ++i)
{
if(d[arr_ec[i].b] < (d[arr_ec[i].a] - arr_ec[i].c) * arr_ec[i].r) break;
}

if(i < 2 * m) cout << "YES" << endl;
else cout << "NO" << endl;

delete [] d;
delete [] arr_ec;

return 0;
}


5.Reference:
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: