您的位置:首页 > 其它

POJ2250——Compromise

2014-11-13 20:57 344 查看
Compromise

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 6614Accepted: 2957Special Judge
Description
In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce
that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do.

Therefore the German government requires a program for the following task:

Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what
both people have in mind).

Your country needs this program, so your job is to write it for us.
Input
The input will contain several test cases.

Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a
line containing a single '#'.

Input is terminated by end of file.
Output
For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline
character.
Sample Input
die einkommen der landwirte
sind fuer die abgeordneten ein buch mit sieben siegeln
um dem abzuhelfen
muessen dringend alle subventionsgesetze verbessert werden
#
die steuern auf vermoegen und einkommen
sollten nach meinung der abgeordneten
nachdruecklich erhoben werden
dazu muessen die kontrollbefugnisse der finanzbehoerden
dringend verbessert werden
#

Sample Output
die einkommen der abgeordneten muessen dringend verbessert werden

Source
Ulm Local 1997

DP题,求LCS

#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;
const int inf = 0x3f3f3f3f;

int a[110], b[110];
char str[33];
int ans[110];
int dp[110][110];
int ch[110][110];

int main()
{
	while (~scanf("%s", str))
	{
		memset (dp, inf, sizeof(dp));
		memset (ch, 0, sizeof(ch));
		map<string, int> bianhao;
		map<int, string> tex;
		bianhao.clear();
		tex.clear();
		int cnt = 0, len1 = 0, len2 = 0;
		bianhao[str] = ++cnt;
		tex[bianhao[str]] = str; 
		a[++len1] = bianhao[str];
		while (scanf("%s", str), str[0] != '#')
		{
			if (bianhao[str] == 0)
			{
				bianhao[str] = ++cnt;
				tex[bianhao[str]] = str; 
			}
			a[++len1] = bianhao[str];
		} 
		while (scanf("%s", str), str[0] != '#')
		{
			if (bianhao[str] == 0)
			{
				bianhao[str] = ++cnt;
				tex[bianhao[str]] = str; 
			}
			b[++len2] = bianhao[str];
		} 
		for (int i = 0; i <= len1; i++)
		{
			dp[i][0] = 0;
		}
		for (int i = 0; i <= len2; i++)
		{
			dp[0][i] = 0;
		}
		for (int i = 1; i <= len1; i++)
		{
			for (int j = 1; j <= len2; j++)
			{
				if (a[i] == b[j])
				{
					dp[i][j] = dp[i - 1][j - 1] + 1;
					ch[i][j] = 1;
				}
				else if(dp[i][j - 1] > dp[i - 1][j])
				{
					dp[i][j] = dp[i][j - 1];
					ch[i][j] = 2;
				}
				else
				{
					dp[i][j] = dp[i - 1][j];
					ch[i][j] = 3;
				}
			}
		}
	 	cnt = dp[len1][len2];
		int i = len1, j = len2;
		while (i > 0 && j > 0)
		{
			if (ch[i][j] == 1)
			{
				ans[cnt--] = a[i];
				i--;
				j--;
			}
			else if(ch[i][j] == 2)
			{
				j--;
			}
			else
			{
				i--;
			}
		}
		for (int i = 1; i <= dp[len1][len2]; i++)
		{
			if (i < dp[len1][len2])
			{
				printf("%s ", tex[ans[i]].c_str());
				continue;
			}
			printf("%s\n", tex[ans[dp[len1][len2]]].c_str());
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: