您的位置:首页 > 其它

POJ 2255 Tree Recovery

2014-11-12 13:14 239 查看
题目来源:http://poj.org/problem?id=2255

Tree Recovery

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11649 Accepted: 7311
Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 

This is an example of one of her creations: 
D

/ \

/   \

B     E

/ \     \

/   \     \

A     C     G

/

/

F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF
and the inorder traversal is ABCDEFG. 

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 

However, doing the reconstruction by hand, soon turned out to be tedious. 

So now she asks you to write a program that does the job for her! 

Input

The input will contain one or more test cases. 

Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 

Input is terminated by end of file. 

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
Sample Input
DBACEGF ABCDEFG
BCAD CBAD

Sample Output
ACBFGED
CDAB

Source

Ulm Local 1997

题意:

给出二叉树的前序和中序遍历,求后序遍历

题解:

根据三种遍历的特点

1.前序遍历: 根 左 右

2.中序遍历:左  根 右 

3.后序遍历:左 右  右

首先根据前序遍历确定根节点,然后再根据中序遍历确定左子树和右子树,然后再按此方法依次递归左子树和右子树并将根节点入栈。

最后,栈中保存的便是该树的后序遍历。

PS: 这题在半年前就看过,那个时候对树的遍历并不熟悉~~ 还不完全理解,也就不会打代码了~  今天中午又把这题翻出来,稍微分析一下很快就实现了。一次AC

AC代码:

#include<iostream>
#include<string>
using namespace std;
int posmap[256];
string pretree,midtree,posttree="";
void init()
{
posttree="";
for(int i=0;i<pretree.size();i++)
posmap[pretree[i]]=i+1;
}
void postorder(int left,int right)
{
if(left==right) return ;
int Min=posmap[midtree[left]],Mpos=left;
for(int i=left+1;i<right;i++){
if(Min>posmap[midtree[i]]){
Min=posmap[midtree[i]];
Mpos=i;
}
}
postorder(left,Mpos);
postorder(Mpos+1,right);
posttree+=midtree[Mpos];
}
int main()
{
while(cin>>pretree>>midtree)
{
init();
postorder(0,midtree.size());
cout<<posttree<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: