您的位置:首页 > 其它

HDU 5090 Game with Pearls(贪心, 二部图最大匹配)

2014-11-11 20:50 543 查看


Game with Pearls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 414    Accepted Submission(s): 212


Problem Description

Tom and Jerry are playing a game with tubes and pearls. The rule of the game is:

1) Tom and Jerry come up together with a number K. 

2) Tom provides N tubes. Within each tube, there are several pearls. The number of pearls in each tube is at least 1 and at most N. 

3) Jerry puts some more pearls into each tube. The number of pearls put into each tube has to be either 0 or a positive multiple of K. After that Jerry organizes these tubes in the order that the first tube has exact one pearl, the 2nd tube has exact 2 pearls,
…, the Nth tube has exact N pearls.

4) If Jerry succeeds, he wins the game, otherwise Tom wins. 

Write a program to determine who wins the game according to a given N, K and initial number of pearls in each tube. If Tom wins the game, output “Tom”, otherwise, output “Jerry”.

 

Input

The first line contains an integer M (M<=500), then M games follow. For each game, the first line contains 2 integers, N and K (1 <= N <= 100, 1 <= K <= N), and the second line contains N integers presenting the number of pearls in each tube.

 

Output

For each game, output a line containing either “Tom” or “Jerry”.

 

Sample Input

2
5 1
1 2 3 4 5
6 2
1 2 3 4 5 5

 

Sample Output

Jerry
Tom

 

Source

2014上海全国邀请赛——题目重现(感谢上海大学提供题目)

 

题目大意:Jerry 和 Tom 玩一个游戏 , 给你 n 个盒子 , a[ i ] 表示开始时 ,第 i 个盒子中的小球的个数 。 然后 Jerry 可以在每个

盒子里加入 0 或 k的倍数的小球 , 操作完后,Jerry 可以重新排列 盒子的顺序,最终使 第 i 个盒子中有 i 个小球。 若Jerry能

使最终的盒子变成那样,就输出 “Jerry” ,否则 输出 “Tom” 。 

解题思路:

方法一、统计后,从小到大分过去,剩下的放到i+k的位置,这样O(n)的可以得到答案。

方法二、转化乘二部图模型,将 初始状态 和 可到达的球数 作为两个集合,符合倍数条件的连边,若最大匹配数=n,则Jerry赢。

#include <iostream>
#include <cstring>
using namespace std;

const int MAXN = 110;
int nCase, n, k, m, cnt[MAXN];

void init() {
memset(cnt, 0, sizeof(cnt));
}

void input() {
cin >> n >> k;
for (int i = 0; i < n; i++) {
int x;
cin >> x;
cnt[x]++;
}
}

void solve() {
for (int i = 1; i <= n; i++) {
if (!cnt[i]) {
cout << "Tom" << endl;
return;
}
cnt[i+k] += cnt[i] - 1;
}
cout << "Jerry" << endl;
}

int main() {
ios::sync_with_stdio(false);
cin >> nCase;
while (nCase--) {
init();
input();
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm-icpc