您的位置:首页 > 其它

HDU 5095 Linearization of the kernel functions in SVM(模拟, 水题)

2014-11-11 20:48 615 查看


Linearization of the kernel functions in SVM

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 512    Accepted Submission(s): 180


Problem Description

SVM(Support Vector Machine)is an important classification tool, which has a wide range of applications in cluster analysis, community division and so on. SVM The kernel functions used in SVM have many forms. Here we only discuss the function of the form f(x,y,z)
= ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j. By introducing new variables p, q, r, u, v, w, the linearization of the function f(x,y,z) is realized by setting the correspondence x^2 <-> p, y^2 <-> q, z^2 <-> r,
xy <->u, yz <-> v, zx <-> w and the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j can be written as g(p,q,r,u,v,w,x,y,z) = ap + bq + cr + du + ev + fw + gx + hy + iz + j, which
is a linear function with 9 variables.

Now your task is to write a program to change f into g.

 

Input

The input of the first line is an integer T, which is the number of test data (T<120). Then T data follows. For each data, there are 10 integer numbers on one line, which are the coefficients and constant a, b, c, d, e, f, g, h, i, j of the function f(x,y,z)
= ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j.

 

Output

For each input function, print its correspondent linear function with 9 variables in conventional way on one line.

 

Sample Input

2
0 46 3 4 -5 -22 -8 -32 24 27
2 31 -5 0 0 12 0 0 -49 12

 

Sample Output

46q+3r+4u-5v-22w-8x-32y+24z+27
2p+31q-5r+12w-49z+12

 

Source

2014上海全国邀请赛——题目重现(感谢上海大学提供题目)

 
现场最水的一题,1A,对代码功和细心程度还是有一定考验的。以下代码是赛后重写的,当时写的比较乱,没用函数,各种重复的if写了10段。。

按平时写数学式子的常理输出。注意几个细节,全0、第一个为正、系数为1、常数项为1等。

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

const int MAXN = 10;
int num[MAXN], nCase;
char alphabet[MAXN] = "pqruvwxyz";
bool isFirst;

void print(int i) {
if (num[i] == 0) return;
if (i == 9) {
if (num[i] < 0) {
printf("%d", num[i]);
} else if (num[i] > 0) {
if (!isFirst) printf("+");
printf("%d", num[i]);
}
} else {
if (num[i] < 0) {
if (num[i] == -1) {
printf("-%c", alphabet[i]);
} else {
printf("%d%c", num[i], alphabet[i]);
}
} else {
if (!isFirst) printf("+");
if (num[i] == 1) {
printf("%c", alphabet[i]);
} else {
printf("%d%c", num[i], alphabet[i]);
}
}
}
isFirst = false;
}

void input() {
for (int i = 0; i < 10; i++) {
scanf("%d", &num[i]);
}
}

void solve() {
isFirst = true;
for (int i = 0; i < 10; i++) {
print(i);
}
if (isFirst) printf("0");
printf("\n");
}

int main() {
scanf("%d", &nCase);
while (nCase--) {
input();
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm-icpc