您的位置:首页 > 其它

POJ-1007

2014-11-11 18:46 399 查看
DNA Sorting

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 84498Accepted: 34028
Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is
greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can
be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''.
All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

Source

East Central North America 1998

#include<stdio.h>
#include<string.h>

void main()
{
int length,line;
int i,j,k,m,n,flag,index;
char str[110][60];
int len[100],len1[100];
scanf("%d %d",&length,&line);
for(n=0;n<line;n++) {
scanf("%s",str
);
for(i=0,m=0;i<length;i++) {
for(j=i+1;j<length;j++){
if(str
[i]>str
[j]) m++;
}
}
len
=m;
}
for(j=0,flag=0;j<line;j++) {
for(i=0,m=60,index=0;i<line;i++){
for(k=0;k<j;k++){
if(len1[k]==i) { flag=1; break;}
else flag=0;
}
if(flag==1) continue;
else{
if(len[i]<m){
m=len[i];
index=i;
len1[j]=i;
}
}
}
printf("%s\n",str[index]);
}
}


wrong answer!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: