您的位置:首页 > 其它

hdu 5001 Walk ( 概率DP )

2014-11-11 17:46 288 查看



Walk

Time Limit: 30000/15000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 610 Accepted Submission(s): 382

Special Judge


Problem Description

I used to think I could be anything, but now I know that I couldn't do anything. So I started traveling.

The nation looks like a connected bidirectional graph, and I am randomly walking on it. It means when I am at node i, I will travel to an adjacent node with the same probability in the next step. I will pick up the start node randomly (each node in the graph
has the same probability.), and travel for d steps, noting that I may go through some nodes multiple times.

If I miss some sights at a node, it will make me unhappy. So I wonder for each node, what is the probability that my path doesn't contain it.

Input

The first line contains an integer T, denoting the number of the test cases.

For each test case, the first line contains 3 integers n, m and d, denoting the number of vertices, the number of edges and the number of steps respectively. Then m lines follows, each containing two integers a and b, denoting there is an edge between node
a and node b.

T<=20, n<=50, n-1<=m<=n*(n-1)/2, 1<=d<=10000. There is no self-loops or multiple edges in the graph, and the graph is connected. The nodes are indexed from 1.

Output

For each test cases, output n lines, the i-th line containing the desired probability for the i-th node.

Your answer will be accepted if its absolute error doesn't exceed 1e-5.

Sample Input

2
5 10 100
1 2
2 3
3 4
4 5
1 5
2 4
3 5
2 5
1 4
1 3
10 10 10
1 2
2 3
3 4
4 5
5 6
6 7
7 8
8 9
9 10
4 9


Sample Output

0.0000000000
0.0000000000
0.0000000000
0.0000000000
0.0000000000
0.6993317967
0.5864284952
0.4440860821
0.2275896991
0.4294074591
0.4851048742
0.4896018842
0.4525044250
0.3406567483
0.6421630037


dp[i][j],状态表示当前在 i 点,已经走了j 步。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
using namespace std;
const int N=10010;
const int M=55;

double dp
[M];
vector <int> G[M];
int n,m,k;

void initial()
{
for(int i=0; i<M; i++)  G[i].clear();
}

void input()
{
scanf("%d %d %d",&n,&m,&k);
int u,v;
for(int i=0; i<m; i++)
{
scanf("%d %d",&u,&v);
G[u].push_back(v);
G[v].push_back(u);
}
for(int i=1;i<=n;i++)  G[0].push_back(i);
}

double solve(int u)
{
double ans=0;
memset(dp,0,sizeof(dp));
dp[0][0]=1;
// double ans=0;
for(int i=0; i<=k; i++)
{
for(int j=0; j<=n; j++)
{
if(j==u)  continue;
double p=1.0/G[j].size();
for(int t=0; t<G[j].size(); t++)
{
int w=G[j][t];
dp[i+1][w]+=dp[i][j]*p;
}
}
ans+=dp[i+1][u];
}
return 1.0-ans;
}

int main()
{
int T;
scanf("%d",&T);
while(T--)
{
initial();
input();
for(int i=1;i<=n;i++)
printf("%.10lf\n",solve(i));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: