您的位置:首页 > 运维架构

Audiophobia - UVa 10048 Floyd

2014-11-10 23:49 741 查看


Audiophobia

Consider yourself lucky! Consider yourself lucky to be still breathing and having fun participating in this contest. But we apprehend that many of your descendants may not have this luxury. For, as you know,
we are the dwellers of one of the most polluted cities on earth. Pollution is everywhere, both in the environment and in society and our lack of consciousness is simply aggravating the situation.

However, for the time being, we will consider only one type of pollution ­- the sound pollution. The loudness or intensity level of sound is usually measured in decibels and sound having intensity level
130 decibels or higher is considered painful. The intensity level of normal conversation is 60­65 decibels and that of heavy traffic is 70­80 decibels.
Consider the following city map where the edges refer to streets and the nodes refer to crossings. The integer on each edge is the average intensity level of sound (in decibels) in the corresponding street.



To get from crossing A to crossing G you may follow the following path: A­C­F­G. In that case you must be capable of tolerating sound intensity as high as 140 decibels.
For the paths A­B­E­G, A­B­D­G and A­C­F­D­G you must tolerate respectively 90, 120 and 80 decibels of sound intensity. There are other paths, too. However, it is clear thatA­C­F­D­G is the
most comfortable path since it does not demand you to tolerate more than 80 decibels.
In this problem, given a city map you are required to determine the minimum sound intensity level you must be able to tolerate in order to get from a given crossing to another.

Input

The input may contain multiple test cases.
The first line of each test case contains three integers

,

and

where Cindicates
the number of crossings (crossings are numbered using distinct integers ranging from 1 to C), Srepresents the number of streets and Q is the number of queries.
Each of the next S lines contains three integers: c1, c2 and d indicating that the average sound intensity level on the street connecting the crossings c1 and c2 (

)
is d decibels.
Each of the next Q lines contains two integers c1 and c2 (

)
asking for the minimum sound intensity level you must be able to tolerate in order to get from crossing c1 to crossing c2.
The input will terminate with three zeros form C, S and Q.

Output

For each test case in the input first output the test case number (starting from 1) as shown in the sample output. Then for each query in the input print a line giving the minimum sound intensity level (in decibels)
you must be able to tolerate in order to get from the first to the second crossing in the query. If there exists no path between them just print the line ``no path".
Print a blank line between two consecutive test cases.

Sample Input

7 9 3
1 2 50
1 3 60
2 4 120
2 5 90
3 6 50
4 6 80
4 7 70
5 7 40
6 7 140
1 7
2 6
6 2
7 6 3
1 2 50
1 3 60
2 4 120
3 6 50
4 6 80
5 7 40
7 5
1 7
2 4
0 0 0

Sample Output

Case #1
80
60
60
 
Case #2
40
no path
80


题意:给你相邻的两个点之间的街道的分贝,问你从u点走到v点的路径上的最大分贝的最小值是多少。

思路:类似于Floyd。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,q,dis[110][110],INF=1e9;
int main()
{
    int t=0,i,j,k,u,v;
    while(~scanf("%d%d%d",&n,&m,&q) && n>0)
    {
        if(t)
          printf("\n");
        printf("Case #%d\n",++t);
        for(i=1;i<=n;i++)
           for(j=1;j<=n;j++)
              dis[i][j]=INF;
        for(i=1;i<=n;i++)
           dis[i][i]=0;
        for(i=1;i<=m;i++)
        {
            scanf("%d%d%d",&u,&v,&k);
            dis[u][v]=dis[v][u]=k;
        }
        for(k=1;k<=n;k++)
           for(i=1;i<=n;i++)
              for(j=1;j<=n;j++)
                 dis[i][j]=min(dis[i][j],max(dis[i][k],dis[k][j]));
        for(i=1;i<=q;i++)
        {
            scanf("%d%d",&u,&v);
            if(dis[u][v]==INF)
              printf("no path\n");
            else
              printf("%d\n",dis[u][v]);
        }
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: