您的位置:首页 > 编程语言 > C语言/C++

Java vs C++

2014-11-10 16:47 501 查看
描述

Apologists of Java and C++ can argue for hours proving each other that their programming language is the best one. Java people will tell that their programs are clearer and less prone
to errors, while C++ people will laugh at their inability to instantiate an array of generics or tell them that their programs are slow and have long source code.

Another issue that Java and C++ people could never agree on is identifier naming. In Java a multiword identifier is constructed in the following manner: the first word is written starting from the small letter, and the following ones are written starting from
the capital letter, no separators are used. All other letters are small. Examples of a Java identifier are javaIdentifier, longAndMnemonicIdentifier, name, nEERC.

Unlike them, C++ people use only small letters in their identifiers. To separate words they use underscore character ‘_’. Examples of C++ identifiers are c_identifier, long_and_mnemonic_identifier, name (you see that when there is just one word Java and C++
people agree), n_e_e_r_c.

You are writing a translator that is intended to translate C++ programs to Java and vice versa. Of course, identifiers in the translated program must be formatted due to its language rules — otherwise people will never like your translator.

The first thing you would like to write is an identifier translation routine. Given an identifier, it would detect whether it is Java identifier or C++ identifier and translate it to another dialect. If it is neither, then your routine should report an error.
Translation must preserve the order of words and must only change the case of letters and/or add/remove underscores.

输入

The input file consists of one line that contains an identifier. It consists of letters of the English alphabet and underscores. Its length does not exceed 100.

输出

If the input identifier is Java identifier, output its C++ version. If it is C++ identifier, output its Java version. If it is none, output “Error!“ instead.

样例输入

sample input #1

long_and_mnemonic_identifier

sample input #2

anotherExample

sample input #3

i

sample input #4

bad_Style

样例输出

sample output #1

longAndMnemonicIdentifier

sample output #2

another_example

sample output #3

i

sample output #4

Error!

#include<iostream>
using std::cin;
using std::cout;
using std::endl;
using std::istream;
using std::ostream;
#include<string>
using std::string;
#include<cctype>

class Identifier{
friend ostream& operator << (ostream& out, const Identifier& src);
friend istream& operator >> (istream& in, Identifier& src);
public:
static const int JAVA_STYLE = 2;
static const int CPP_STYLE = 1;
static const int BAD_STYLE = 0;
Identifier(const string _name = "noName"){
data = _name;
length = _name.length();
}
char& operator [](const string::size_type& index){
return data[index];
}
int style(void);
Identifier java_style(void);
Identifier cpp_style(void);
private:
string data;
string::size_type length;
};

ostream& operator << (ostream& out, const Identifier& src){
out << src.data;
return out;
}

istream& operator >> (istream& in, Identifier& src){
in >> src.data;
src.length = src.data.length();
return in;
}

int Identifier::style(void){
if (!islower(data[0]) || data[length - 1] == '_'){
return BAD_STYLE;
}
if (data.find('_') != string::npos){
//it can not be java style!
for (string::size_type index(1); index != length; ++index){
if (isupper(data[index])){
return BAD_STYLE;
}
if (data[index - 1] == '_' && data[index] == '_'){
return BAD_STYLE;
}
}
return CPP_STYLE;
}
else{
return JAVA_STYLE;
}
}

Identifier Identifier::cpp_style(void){
string result;
for (string::size_type index(0); index != length; ++index){
if (isupper(data[index])){
result.append(1, '_');
result.append(1, tolower(data[index]));
}
else{
result.append(1, data[index]);
}
}
return Identifier(result);
}

Identifier Identifier::java_style(void){
string result;
for (string::size_type index(0); index != length; ++index){
if (data[index] == '_'){
++index;
result.append(1, toupper(data[index]));
}
else{
result.append(1, data[index]);
}
}
return Identifier(result);
}

int main(void){
Identifier identifier;
while (cin >> identifier){
switch (identifier.style()){
case Identifier::JAVA_STYLE:
cout << identifier.cpp_style() << endl;
break;
case Identifier::CPP_STYLE:
cout << identifier.java_style() << endl;
break;
default:
cout << "Error!" << endl;
}
}
return EXIT_SUCCESS;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: