您的位置:首页 > 其它

hdu1009-FatMouse' Trade --- 贪心算法

2014-11-09 01:04 381 查看
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 44989 Accepted Submission(s): 15050



Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.



Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All
integers are not greater than 1000.



Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.



Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1




Sample Output

13.333
31.500




Author

CHEN, Yue



Source

ZJCPC2004



Recommend

JGShining | We have carefully selected several similar problems for you: 1050 1005 1051 1003 2037

题意:

共有n个房子,每个房子里有老鼠喜欢吃的javabeans,但是每个房间里的javabeans的价格不一样。老鼠用m元,问m元最多可以卖多少javabeans,其中每个房间里的javabeans可以被分割。

解题分析:

首先看到了题目的时候可以向这个题是一道水题,不过需要注意的是处理除法的时候。还有这里用到的是贪心算法。

代码:

#include <iostream>

#include <cstdio>

#define MAXN 1002

int J[MAXN] = {0};

int F[MAXN] = {0};

double JF[MAXN] = {0};

int main()

{

int N, M;

double sum, temp;

while(scanf("%d%d", &N, &M) != EOF && N != -1 && M != -1)

{

for(int i=1; i <= M; ++i)

{

scanf("%d%d", &J[i], &F[i]);

JF[i] = J[i]*1.0/F[i];

}

for(int i=2; i <= M; ++i)

{

if(JF[i] >= JF[i-1])

{

JF[0] = JF[i];

J[0] = J[i];

F[0] = F[i];



JF[i] = JF[i-1];

J[i] = J[i-1];

F[i] = F[i-1];



for(int j=i-2; j>=0; --j)

{

if(JF[0] >= JF[j])

{

JF[j+1] = JF[j];

J[j+1] = J[j];

F[j+1] = F[j];

}

else {

JF[j+1] = JF[0];

J[j+1] = J[0];

F[j+1] = F[0];

break;

}

}

}

}



sum = 0;

temp = N;

for(int i=1; i <= M; ++i)

{

temp = temp - F[i];

if(temp >= 0)

sum += 1.0*J[i];

else

{

sum += (temp + F[i])*JF[i];

break;

}



}

printf("%.3lf\n", sum);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: