您的位置:首页 > 产品设计 > UI/UE

hdoj 1711 Number Sequence 【KMP】

2014-11-07 23:46 302 查看

Number Sequence

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 11817 Accepted Submission(s): 5395

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M].
If there are more than one K exist, output the smallest one.



Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate
a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].



Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.



Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1




Sample Output
6
-1


KMP模板

代码:

#include <stdio.h>
#include <string.h>
#define M 10005
#define N 1000005

int a
, b[M], next[M], n, m;

void get_next(){
	int i, j, k;
	i = 1; j = 0;
	while(i<= m){
		if(j==0||b[i] == b[j]){
			++i; ++j; next[i] = j;
		}
		else j = next[j];
	}
}

int kmp(){
	int i, j;
	i = 1, j = 1;
	while(i<=n&&j<= m){
		if(j == 0||a[i] == b[j]){
			++i; ++j;
		}
		else j = next[j];
	}
	if(j > m) return i-j+1;
	return -1;
}

int main(){
	int t;
	scanf("%d", &t);
	while(t --){
		scanf("%d%d", &n, &m);
		memset(next, 0, sizeof(next));
		next[1] = 0;
		int i, j;
		for(i = 1; i <= n; i ++) scanf("%d", &a[i]);
		for(i = 1;  i <= m; ++ i) scanf("%d", &b[i]);
		get_next();
		int ans = kmp();
		printf("%d\n", ans);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: