您的位置:首页 > 其它

hdu 1060 Leftmost Digit

2014-11-07 21:49 309 查看


Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13503 Accepted Submission(s): 5187



Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the leftmost digit of N^N.

Sample Input

2
3
4


Sample Output

2
2

Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.题目大意:求n的n次方的最左边的那个数
思路:数学公式,一个数的位数等于(int)lg(n)+1 ;
2014,11,7
感觉还是有点毛病
#include<stdio.h>
#include<math.h>
int main(){
int t,n,b;
__int64 m;
scanf("%d",&t);
while(t--){
scanf("%d",&n);
m=(__int64)(n*log10(n));//n的n次方的位数是n*lg(n)+1,又因为A=b*10m次方,所以
//	m等于位数-1,即n*lg(10);
b=pow(10.0,(n*log10(n)-m));//lgb=n*lg(n)-m
printf("%d\n",b);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: