您的位置:首页 > 其它

poj 1269(求两线段交点)

2014-11-06 23:35 302 查看
Intersecting Lines

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 11300Accepted: 5106
Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they
are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect.

Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4.
Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).
Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point.
If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".
Sample Input
5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output
INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

题意:给出两条线段,求这两条是否平行、共线或相交,若相交,求出交点。

AC代码:
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#define ll long long
using namespace std;

const int maxn = 105;
const int INF = 1e9;
const double eps = 1e-8;

struct point{
double x, y;
}p[4];
int n;
double multi(point p1, point p2, point p0){
return (p1.x - p0.x) * (p2.y - p0.y) - (p2.x - p0.x) * (p1.y - p0.y);
}
bool parallel(point u1, point u2, point v1, point v2){
return fabs((u1.x - u2.x) * (v1.y - v2.y) - (v1.x - v2.x) * (u1.y - u2.y)) < eps;
}
point intersection(point u1, point u2, point v1, point v2){
point ret=u1;
double d1 = (u1.x - v1.x) * (v1.y - v2.y) - (u1.y - v1.y) * (v1.x - v2.x);
double d2 = (u1.x - u2.x) * (v1.y - v2.y) - (u1.y - u2.y) * (v1.x - v2.x);
double t = d1 / d2;
ret.x += (u2.x - u1.x)*t;
ret.y += (u2.y - u1.y)*t;
return ret;
}
int main(){
int n;
scanf("%d", &n);
printf("INTERSECTING LINES OUTPUT\n");
while(n--)
{
for(int i = 0; i < 4; i++)
scanf("%lf%lf", &p[i].x, &p[i].y);
if(multi(p[0], p[1], p[2]) == 0 && multi(p[0], p[1], p[3]) == 0)
{
printf("LINE\n");
continue;
}
if(parallel(p[0], p[1], p[2], p[3]))
{
printf("NONE\n");
continue;
}
point ans = intersection(p[0], p[1], p[2], p[3]);
printf("POINT %.2f %.2f\n", ans.x, ans.y);
}
printf("END OF OUTPUT\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: