您的位置:首页 > 其它

HDU 1.3.8 As Easy As A+B

2014-11-06 16:27 363 查看

As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2553 Accepted Submission(s): 1235
Problem Description
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.

Give you some integers, your task is to sort these number ascending (升序).

You should know how easy the problem is now!

Good luck!


Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and
then N integers follow in the same line.

It is guarantied that all integers are in the range of 32-int.


Output
For each case, print the sorting result, and one line one case.


Sample Input
2
3 2 1 3
9 1 4 7 2 5 8 3 6 9



Sample Output
1 2 3
1 2 3 4 5 6 7 8 9



乍一看的确好像挺简单,实际上也简单,只是从这个题目开始,对输出格式严格了一点点,每行输出结尾不能带空格

菜鸟级的原创代码,已AC。若有可提高之处欢迎指导

//#define LOCAL
#include<stdio.h>
#include<string>
#include<algorithm>
using std::sort;
bool cmp(int a, int b)
{
return a < b;
}

int main()
{
#ifdef LOCAL
freopen("H://dataIn.txt", "r", stdin);
freopen("H://dataOut.txt", "w", stdout);
#endif
int a[1000];
int n;
scanf("%d", &n);

for (int k = 0; k < n; k++)
{
int m;
scanf("%d", &m);
memset(a, 0, sizeof(a));
for (int u = 0; u < m; u++)
scanf("%d", &a[u]);
sort(a, a + m, cmp);
for (int j = 0; j < m-1; j++)
printf("%d ", a[j]);
printf("%d\n",a[m-1]);
}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: