您的位置:首页 > 其它

a letter and a number

2014-11-04 21:36 274 查看


a letter and a number描述

we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;

Give you a letter x and a number y , you should output the result of y+f(x).

输入On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000).输出for each case, you should the result of y+f(x) on a line样例输入
6
R 1
P 2
G 3
r 1
p 2
g 3

样例输出
19
18
10
-17
-14
-4


解题思路:


本题涉及n组数据,而每组数据开头都是字符,scanf读取字符是会先读取换行,所以应当在读取每行数据之前,用getchar将回车吃掉,否知只能读取一半数据。


程序代码:


#include<stdio.h>
int main()
{
int n,y,i;
char x;
scanf("%d",&n);
while(n--)
{
getchar();
scanf("%c%d",&x,&y);
if(x>='a'&&x<='z')
printf("%d\n",'a'-x-1+y);
else if(x>='A'&&x<='Z')
printf("%d\n",x-'A'+1+y);

}
return 0;
}

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: