您的位置:首页 > 其它

POJ 3356-AGTC(区间DP)

2014-11-04 13:40 204 查看
AGTC

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10225Accepted: 3949
Description

Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:

Deletion: a letter in x is missing in y at a corresponding position.
Insertion: a letter in y is missing in x at a corresponding position.
Change: letters at corresponding positions are distinct

Certainly, we would like to minimize the number of all possible operations.

Illustration

A G T A A G T * A G G C

| | |       |   |   | |

A G T * C * T G A C G C


Deletion: * in the bottom line

Insertion: * in the top line

Change: when the letters at the top and bottom are distinct
This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like

A  G  T  A  A  G  T  A  G  G  C

|  |  |        |     |     |  |

A  G  T  C  T  G  *  A  C  G  C


and 4 moves would be required (3 changes and 1 deletion).

In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where n ≥ m.

Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.

Write a program that would minimize the number of possible operations to transform any string x into a string y.

Input

The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output

An integer representing the minimum number of possible operations to transform any string x into a string y.

Sample Input
10 AGTCTGACGC
11 AGTAAGTAGGC

Sample Output
4

类似于编辑距离问题。。dp[i][j]代表 x串从1-i与y串从1-j已经匹配好的最少操作数。

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <list>
#define ll long long
using namespace std;
const int INF = 0x3f3f3f3f;
int dp[1025][1025];
char a[1025],b[1025];
int My_min(int x,int y,int z)
{
	return min(min(x,y),z);
}
int main()
{
	int lena,lenb;
	while(scanf("%d %s %d %s",&lena,a,&lenb,b)!=EOF){
	for(int i=0;i<=lenb;i++)
		dp[0][i]=i;
	for(int i=0;i<=lena;i++)
		dp[i][0]=i;
	for(int i=1;i<=lena;i++)
		for(int j=1;j<=lenb;j++)
		dp[i][j]=My_min(dp[i-1][j]+1,dp[i][j-1]+1,a[i-1]==b[j-1]?dp[i-1][j-1]:dp[i-1][j-1]+1);
	printf("%d\n",dp[lena][lenb]);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: