您的位置:首页 > 其它

2014上海全国邀请赛1001(hdu 5090)

2014-11-02 22:45 555 查看


Game with Pearls

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 98 Accepted Submission(s): 72



Problem Description

Tom and Jerry are playing a game with tubes and pearls. The rule of the game is:

1) Tom and Jerry come up together with a number K.

2) Tom provides N tubes. Within each tube, there are several pearls. The number of pearls in each tube is at least 1 and at most N.

3) Jerry puts some more pearls into each tube. The number of pearls put into each tube has to be either 0 or a positive multiple of K. After that Jerry organizes these tubes in the order that the first tube has exact one pearl, the 2nd tube has exact 2 pearls,
…, the Nth tube has exact N pearls.

4) If Jerry succeeds, he wins the game, otherwise Tom wins.

Write a program to determine who wins the game according to a given N, K and initial number of pearls in each tube. If Tom wins the game, output “Tom”, otherwise, output “Jerry”.

Input

The first line contains an integer M (M<=500), then M games follow. For each game, the first line contains 2 integers, N and K (1 <= N <= 100, 1 <= K <= N), and the second line contains N integers presenting the number of pearls in each tube.

Output

For each game, output a line containing either “Tom” or “Jerry”.

Sample Input

2
5 1
1 2 3 4 5
6 2
1 2 3 4 5 5


Sample Output

Jerry
Tom


题意:给你n和k,然后n个数,能对任意一个数加上0或者k的倍数,让你判断是否操作完之后并且排序之后能行程1,2...n的序列。

做法:直接n^2暴力扫过去。。。。因为n比较小。

#include <iostream>
#include <cstdio>
#include <climits>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include<map>
#include <algorithm>
#include<ctime>
#define esp 1e-6
#define LL unsigned long long
#define inf 0x0f0f0f0f
using namespace std;
bool cmp(int a,int b)
{
return a<b;
}
int main()
{
int t,i,j;
int n,k;
int num[1050],vis[1005],ans[1005];
scanf("%d",&t);
while(t--)
{
memset(vis,0,sizeof(vis));
memset(ans,0,sizeof(ans));
scanf("%d%d",&n,&k);
for(i=1;i<=n;i++)
scanf("%d",&num[i]);
sort(num+1,num+1+n);
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
if(i>=num[j]&&(i-num[j])%k==0&&vis[j]==0)
{
ans[i]=1;
vis[j]=1;
break;
}
}
}
int flag;
flag=0;
for(i=1;i<=n;i++)
if(ans[i]==0)
flag=1;
if(flag==1)
printf("Tom\n");
else
printf("Jerry\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: