您的位置:首页 > 其它

hdu 5087 Revenge of LIS II(BestCoder Round #16)

2014-11-02 11:09 489 查看


Revenge of LIS II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 528 Accepted Submission(s): 173



Problem Description

In computer science, the longest increasing subsequence problem is to find a subsequence of a given sequence in which the subsequence's elements are in sorted order, lowest to highest, and in which the subsequence is as long as possible. This subsequence is
not necessarily contiguous, or unique.

---Wikipedia

Today, LIS takes revenge on you, again. You mission is not calculating the length of longest increasing subsequence, but the length of the second longest increasing subsequence.

Two subsequence is different if and only they have different length, or have at least one different element index in the same place. And second longest increasing subsequence of sequence S indicates the second largest one while sorting all the increasing subsequences
of S by its length.

Input

The first line contains a single integer T, indicating the number of test cases.

Each test case begins with an integer N, indicating the length of the sequence. Then N integer Ai follows, indicating the sequence.

[Technical Specification]

1. 1 <= T <= 100

2. 2 <= N <= 1000

3. 1 <= Ai <= 1 000 000 000

Output

For each test case, output the length of the second longest increasing subsequence.

Sample Input

3
2
1 1
4
1 2 3 4
5
1 1 2 2 2


Sample Output

1
3
2
HintFor the first sequence, there are two increasing subsequence: [1], [1]. So the length of the second longest increasing subsequence is also 1, same with the length of LIS.


找第二大的上升子序列。

开个数组再记录第二大的就行了。

官方题解:

LIS的O(N2)做法是dp[i]=max(dp[j]|a[j]<a[i])+1。如果需要第二大的,再额外DP一个至少有两个不同递增序列结束在i的最大长度。那么dpdirty[i]=max(dpdirty[j]|a[j]<a[i])+1,或者dpdirty[i]=max(dp[j]|Count[dp[j]]>1)+1。
这个思路不是很容易推广到O(NlogN)的LIS算法中,诸位可以思考一下。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=1110;
int dp[maxn][2];
int a[maxn];
int ans[2*maxn];
int cur;
int main()
{
int t,n;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(int i=0; i<n; i++)
scanf("%d",&a[i]);
cur=0;
memset(dp,0,sizeof(dp));
for(int i=0; i<n; i++)
{
dp[i][0] = 1;
for(int j=0; j<i; j++)
if(a[j]<a[i])
{
int x = dp[j][0] + 1;
int y = dp[j][1] + 1;
if(x>dp[i][0])
swap(dp[i][0],x);
if(x > dp[i][1])
dp[i][1] = x;
if(y > dp[i][1])
dp[i][1] = y;
}
ans[cur++] = dp[i][0];
ans[cur++] = dp[i][1];
}
sort(ans,ans+cur);
printf("%d\n",ans[cur-2]);
}
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: